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WELCOME TO STUDIOCODE – THE ULTIMATE GAME PLAN

This manual will help you find your way around Studiocode. This manual includes descriptions 
for Studiocode. This manual assumes you have already seen a demonstration or been trained 
in using Studiocode and therefore have some knowledge base of how it works. If you are 
unfamiliar with the Studiocode suite of products, or require more information, please email 
Sportstec at support@sportstec.com.

OVERVIEW OF STUDIOCODE

Using Studiocode is easy – just follow some simple steps and you’ll be on your way.

Here’s a quick guide how the Studiocode process works for a new movie. You’ll find step by step 
instructions in the following pages.

1. Click on the Studiocode icon in the dock or on your desktop.
2.  Create a new Code window. This is the window where you can edit and utilize code buttons 

which are designed to categorize the events in the performance.
3.  Decide which actions in the performance (the movie) you want to categorize (code) for fu-

ture analysis. Create and name code buttons for all the actions. For example: you may want 
to code a particular person, a particular action, or each time a specific event occurs. Each 
button will code instances for the actions in the timeline.

5.  Capture (record) the movie to the hard drive and at the same time code the information you 
need using the code window.

6.  You now have the movie captured and the information about the movie coded in a time-
line. The movie and the timeline are linked together and are a chronological record of the 
instances you have coded.

7.  You can now analyze performance according to the information on the timeline. If you want 
to change the information, add to it or delete from it, it’s easy. Studiocode is completely flex-
ible to fit your needs.

Welcome to Studiocode – You’ll wonder how you ever did without it!
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STUDIOCODE SET-UP REQUIREMENTS

The minimum recommended computer requirements for Studiocode are:
·  Apple 1.5Ghz G4 computer with 1GB RAM and 80 GB hard drive space. We highly recommend 

getting the latest available Apple computer.
·  Mac OS X 10.4 (Tiger)
·  DV video camera. Look for models with AV-DV IN/OUT features.
·   Firewire analog to digital video convertor. These devices are used when the camera does not 

support AV-DV IN/OUT. Canopus or Datavideo product lines are recommended.
·   Composite RCA video or s-video cables and RCA audio cables to connect the video source 

(VHS player or DVD player) to a convertor and to output movie presentations to a display or 
recording device.
·   Firewire cables to plug in the camera or convertor to the computer. 4 to 6 pin and 6 to 6 pin 

are recommended.

STUDIOCODE TERMS
Many terms in this manual are specific to Studiocode. Here’s a brief explanation of the most 
common terms.

Code Window
 The file for creating and using code buttons to categorize events in a timeline.

Capture
 To record a movie to a file on the hard disk drive.

Code
  A category for information in your movie. When you want to keep a piece of action from a 

movie for later reference/analysis you code that snippet with a code button.

Code Button
  Code buttons are used to define an action by its name and time when it occurred in a movie. 

For example you may name a code button “Direction” to mark every time a direction is given 
by a participant. Code buttons are toggle buttons, up or down, except when you have a lag 
time programmed which creates a fixed-length instance.

Database
  A database is a timeline created by exporting selected instances from one or multiple 

timelines. The database process only exports the specified code and movie data. This process 
removes all the unwanted code and movie data and allows you to compile information in one 
file.

Instance
  An instance is a coded segment of a movie. An instance becomes part of the timeline for that 

movie (also see code).
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Lag Time
  Lag time automatically adds a specific time to the end of an instance when it is being coded. 

When you click on the code button to code the instance, Studiocode automatically adds 
the lag time to its end. Lag time creates a button that only needs to be pressed once. The 
beginning of the instance is marked when the button is pressed down and the end is marked 
when the lag time runs out.

Lead Time
  Lead time automatically adds a specific time to the beginning of an instance when it is being 

coded. When you click on the code button to code the instance Studiocode adds the time to 
its beginning.

Movie
 The performance you are using as the source of your information.

Package
 A special type of folder that contains timeline and movie data.

Title
  A title button is an inactive rectangle used to title a set of buttons. Title buttons can also be 

graphics in the window that do not perform any actions.

Timeline
  The window that displays a timeline showing each instance of all code buttons chronologically 

recorded.
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THE STUDIOCODE MAIN TOOL BAR

 

 Open file   Opens saved files.

 

 Undo Removes the last action.

 Save  Saves the file.

 Capture Opens the capture movie window.

 Volume Selects the speaker volume level.

 Playback rate control  Temporarily sets the playback speed for all movies.

 Loop mode Sets the playback mode for play once or repeat.

  Fast forward/Fast rewind Steps forward or backwards 1 second.

 Play/Pause Plays or pauses the movie.

 Forward/Back Steps forward or backwards 1 frame at a time.

 Present Movie Plays the movie full screen.

 Drawing Tool Bar Opens the drawing tool bar.

 Export to DV Device Export DV format movie to external DV device.
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KEYBOARD SHORTCUTS

MENU ITEM - FUNCTION KEYSTROKE

COMMAND ⌘
CONTROL ⌃
OPTION ⌥
SHIFT ⇧
LEFT  RIGHT  UP  DOWN ARROWS ← → ↑ ↓
PAGE UP  PAGE  DOWN fn↑   fn↓
CLICK )
FILE

Open ⌘O

Open all timelines in folder ⌥⌘O

Save ⌘S

Save as ⇧⌘S

Print ⌘P

Quit ⌘Q

Combine timeline windows * ⌘L

EDIT

Undo ⌘Z

Cut ⌘X

Copy ⌘C

Paste ⌘V

Select all ⌘A

Cut movie segment * ⌃⌘X

Copy movie segment * ⌃⌘C

Paste movie segment * ⌃⌘V

Delete movie segment * ⌃⌘⌫
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KEYBOARD SHORTCUTS...
EDIT

Instance edit ⌃E

Instance trim ⌃T

Nudge all instances left ⇧⌘L

Nedge all instances right ⇧⌘R

Fine and replace ⌥⌘F

Nedge sound track left ⌃⌥⌘L

Nudge sound track right ⌃⌥⌘R

Contract sound track ⌥⌘L

Expand sound track ⌥⌘R

WINDOWS

Present movie (Full screen) ⌘M

Make movie ⌥⌘M

Full screen coding * ⇧⌘F

Play backwards ⌃J

Stop movie ⌃K

Play movie ⌃L

Stack instance movies ⌘Y

Overlay movies ⌥⌘Y

Reduce movie size ⌘< (Use ⇧, for <)

Increase movie size ⌘> (Use ⇧, for >)

Reduce transparency ⌃⌥9

Increase transparency ⌃⌥0

Close all instance movies ⌘I

Close window ⌘W

Hide / Show drawing tool bar ⇧⌥D

Quit full screen presentation ESC
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KEYBOARD SHORTCUTS...
ROWS

Add row ⌘N

CAPTURE

Open capture window ⌘R

Quickstart capture ⌃⌘R

Stop capture ⌘. (Period / Full stop)

Pause / Resume capture ⌘K

MOVIE WINDOW & PLAYBACK

Play / Stop ↑  ↓
Play / Stop Space Bar

Slow motion forward play Hold down →
Smooth rewind play Hold down ←
Fast forward play (1/10 sec steps) ⌘→
Fast rewind play (1/10 sec steps) ⌘←
Faster forward play (1/4 sec steps) ⇧→
Faster rewind play (1/4 sec steps) ⇧←
Fastest forward play (1 sec steps) ⌥→
Fastest rewind play (1 sec steps) ⌥←
Turbo forward play (10 sec steps) ⌃→
Turbo rewind play (10 sec steps) ⌃←
Play stack movie angle full screen ⌃⌥⌘ ) on movie angle

Move movie angle in stack ⌘ ) & Drag

Select segment of instance movie ⇧ ) & Drag instance movie playhead

TIMELINE WINDOW

Create an instance in selected row ⌥⌘ ) & Drag instance movie playhead

Extend or shorten instance ⌥⌘ ) & Drag on leading or trailing edge 
of instance

Duplicate instance ⌥ ) & Drag from instance to other row
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KEYBOARD SHORTCUTS...
CODE WINDOW

Duplicate button ⌘ ) & Drag from a button

Move selected button ← → ↑ ↓
Edit button window, apply button property to 
selected buttons

⌃) on button property text

Move group of buttons ⌘) on selected buttons

Move selected button to top layer ⌃↑
Move selected button to bottom layer ⌃↓
Move selected button up 1 layer ⌃→
Move selected button down 1 layer ⌃←
Toggle Code/Edit mode ⌘↑ or ⌘↓
Stop all code buttons TAB

Deactivate last code button pressed ESC

GENERAL

Preferences ⌘,
Hide Studiocode ⌘H

Hide Others ⌥⌘H

MAC OS X ⌥→
Screen snap shot to file ⇧⌘3

Selection snap shot to file ⇧⌃⌘3

Screen snap shot to memory ⇧⌘4    ⌘V to paste to another window

Selection snap shot to memory ⇧⌃⌘4    ⌘V to paste to another window

Enable display zoom ⌘⌥8

Zoom out display ⌘⌥-

Zoom in display ⌘⌥=
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REGISTRATION OF STUDIOCODE

Before You Start Using Studiocode

Studiocode will only run if you have either inserted a dongle (software 
protection key) or registered an online code over the internet. 

Make sure you close all other applications while you’re using  
Studiocode.

When you launch Studiocode for the first time, you will see the following dialogue box.

Choose online to register online or dongle to use the dongle registration method.

Online Registration

If you select to register online you will then be presented with a registration process dialogue 
box. You must have your computer connected to the internet before you do this.

The serial code that you received with the software should be put into the registration code box 
of the window. If you input the code correctly you will see a red tick at the end of the text box.

C l i c k - ing will connect your computer to the Sportstec internet registration 
s e r v e r and carry out the registration process.

Successful registration is indicated by: 
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Dongle Registration

Please connect your dongle to a USB port on your computer. Select dongle registration and you 
will then be presented with a registration process dialogue box.

The registration code that you received 
with the software should be put into the 
registration code line.

C l i ck ing will complete the 
registration process.

Successful registration is indicated by: 

Change the Registration Mode

1.  Select the Studiocode application menu on the top left of the main menu bar, then Change 
registration code...

2.  If you inadvertently select the incorrect registration method, you can change this during the 
launching process by holding down the ESC key when clicking on the icon.

CHOOSING LANGUAGE

There are two options that can be used to run Studiocode on a non-English operating system. 
Method 1 is probably the easiest to implement and allows you to temporarily switch languages 
(see next page).

If this temporary method is not satisfactory, the second method is more permanent. This more 
permanent method would mean that you could have specific local language or English versions. 
To run in English, you would start the English version and it would use English irrespective of 
the operating system.

Please note: We will use Japanese examples to outline the steps required to choose your language options.
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CHOOSING LANGUAGE...

There are two ways to do this: 

Forcing Studiocode to run in English 
irrespective of the Operating System (OS).

1. Make a copy of Studiocode and rename 
it to distinguish it 
from the original. In 

this example, it has been appended with 
‘(Eng)’.

2.  Hold down the control key and click 
on the duplicated version, and select 
‘Show Package Contents’.

3.  Click the list view so that it is easier to 
see the contents.
4. Expand the  
   view until you see 

something like 
this.

5.  The folders 
ending in 
‘.lproj’ define 
the language 
p r e fe r e n c e s . 
You can see that 
this version of 
Studiocode is 
set up to handle 
5 different 
l a n g u a g e s . 
( A u s t r a l i a n 
Eng l i sh . lp ro j 
is used for 
t e s t i n g . ) 
S t u d i o c o d e 
uses this list 
to try to match 
the language 
used in the 
international 
l a n g u a g e 
preferences. 

If all but the ‘English.lproj’ folder is 
renamed (or removed) then Studiocode 

For Example: Running Studiocode in 
English on a Japanese Operating System.

1.  Quit Studiocode if it is running.
2. Go to System Preferences.
3.  Choose International in the personal 

settings area.
4.  Click the language tab. Your preferences 

should look like this if you are running a 
Japanese operating system.

5. Drag English to the top position.
6.  Start Studiocode. It should start in 

English.
7.  When the session is finished, the user 

should reset the order of languages 
found prior to changing them in the 
steps described above.

Please note: This order can affect the operating 
system if the user logs out or reboots. For 
example, if the order in step 5 was used, and the 
user logged out and logged in again, or rebooted 
the system, the operating system would run in 
English.

21
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GENERAL PREFERENCES FOR STUDIOCODE

The Preferences Window provides you with a series of general settings for Studiocode.
Here’s a brief explanation of the terms: 

·  Auto save timeline data will automatically save the Timeline when you close it.

·  Auto play movies created sets movies to automatically begin playing when they are 
created.

·  Auto load files opens all the files that were last open when Studiocode was quit.

·  Equalize video and sound tracks when capturing allows you to force the sound and video 
to be captured as synched signals. This is only required for some early DV cameras and 
recorders. 

·  Full screen movies using single fields improves the movie quality when viewed on a television 
set. 

·  Duration of text movies for instances sets the length that static text movies or title rows will 
play for prior to an instance or the next row.

·  Maximum number of instance movies sets the number of instances movies that can be 
opened at one time. When the maximum number of instance movies are opened, each newly 
created instance movie will close the oldest one.

·  Group and Everyone access permissions set the default permissions for files being saved 
by Studiocode.
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LAUNCH STUDIOCODE

Click on the icon in the Dock or double click on the Studiocode icon on your desktop or 
in the Applications folder.

THE CODE WINDOW

The Studiocode code window is the starting point for coding your movies. It will contain all 
the categories (buttons) you want to analyze such as set pieces in a field hockey game. Code 
buttons are used to categorize and mark the time of events in your movie. These events, or 
instances, become your own personal study of performance-specific information. You can save 
time by coding instances as you capture your movie. Then if you want to change, add or delete 
information, it’s easy to go back and do so later.

Create a New Code Window

1.  Choose File > New > Code window from the main 
menu bar.

2.  To create a code button, click and drag from the code button icon in the tool bar to 
the blank area below.

Note: Code windows have two basic modes Code and Edit. You will notice a halo around the icons in the tool 
bar to indicate which mode is active. Use Edit mode to change button properties, location, and size. Use Code 
mode to code the timeline with your events. A convenient shortcut is OPTION+UP ARROW or OPTION+DOWN 
ARROW to change modes.
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STUDIOCODE BUTTON TYPES

Code Button 
 Code buttons are identified with a diamond symbol.

·  Name a code button to define an event which will become an instance in the 
timeline. For example: you may name a code button “Student 1” for a classroom 
situation.

 ·  When you have captured a movie and used a code button, the button makes a row 
in the left column of the timeline.

 ·  The code button identifier symbol, a diamond, will be either red or green. A red 
diamond means it has a toggle action that must be clicked on to start coding an 
instance and click on it again to stop coding. A green diamond means the button 
has a lag time and will stop coding at the predefined lag time after it has been 
clicked.

Text Label Button 
 Text label buttons are identified with a circle symbol.

·  Name a text label button with a description or a consequence of an event marked 
by a code button. This label is attached to the last open coded instance on the 
timeline or all active code buttons pressed down. For example, you may name a text 
label button “Good Communication” for a “Student” code button.

 ·  Labels in an instance can be quickly viewed by mousing over an instance in the 
timeline. The text labels will appear above the playhead strip.

Title Button
Title Buttons are identified with a yellow square. 

·  A title button does not perform any coding action, it is only used to put headings, 
comments or graphics within the code window. Clicking on this item during coding 
has no effect within the timeline, no instance is marked when it is clicked.

Graphic Button
 An image can be copied and pasted into the code window. It is called a graphic 
button.

·  By default, a graphic button will be created as a code button. The identifier of a 
graphic button appears in the center of the image. Graphic buttons cannot be resized 
in the code window. Graphic or title buttons can be replaced by other graphics using 
the right click drop down menu on the button and selecting copy or paste.
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EDITING BUTTONS

Edit A Button

1.  In the code window, double click on the 
button you want to edit. This opens the 
edit button window. You can also right 
click on the button and select edit button 
from the drop down menu.

2.  Change the button properties. Click OK to 
commit changes or cancel to close win-
dow and not save changes.

3.  To speed up the editing process, leave 
the edit button properties window open 
and click on another button in the code 
window. This saves the previous button 
properties and switches to the selected 
button. Click OK to commit changes and 
close the window.
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EDITING BUTTONS...

Change A Button Name

 Double click on the button you want to 
change. In the edit button window, change 
its name in the text box.

Change A Button Color

 Click and drag from the color chip into the 
color palette and select a color. Code rows 
can be sorted by color in the timeline. The 
sorting scheme moves from left to right in 
the palette starting at the top row to the bot-
tom row.

Use A Picture As A Graphic Button

Any image can be used as a button in the code window. Copy any image to 
the clipboard and then paste the image into the code window.

1.  A quick way to add a graphic to a code window is to copy (COMMAND+C) from any draw-
ing software.

  Using a Mac OS feature, you can select a picture or graphic from anything on the screen. 
Press SHIFT+CONTROL+COMMAND+4 keys, then click and drag over the area to be 
copied. Paste your copied image into the code window (COMMAND+V).

2.  To paste an image to an existing button, press the CONTROL key and click on the button. 
From the drop down menu select Paste image. 
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EDITING BUTTONS...

Change the Position of a Button Name

1. Click on the points of the text positioning tool.
2. Click in the center box to reset the position to the center of the button.

Change the Text Color of a Button Name

Click on the color chip to the left of Show name and drag into the color palette to 
select the color.

Change the Visibility of a Button Name

Check the Show name check box to display the name of the button. 

Change the Font Size of a Button Name

Select the Size from the drop down menu to set the font size for the name. 

Frame a Button 

Check the Frame button check box to show a black frame around the button.

Lock a Button Position 

Check the Lock position check box to lock the button in place.

Wrap Button Text
Check the Wrap text check box to wrap the text to the shape of the button.

Display Output*
Check the display output check box to display cell information from a 
statistical window.

Change a Button Function

1.  Double click on the button you want to 
change.

2.  In the Edit Button Window, change the 
selection from code to title or text label.
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EDITING BUTTONS...

Populate Rows in Timeline Automatically

 

Check the populate box to automatically 
populate the timeline with code rows upon code 
or capture mode activation.

Blocking Labels

While coding, you will find that you may want to block labels from inserting into certain codes, 
so the labels do not end up in the wrong code. There are two options to help with this.

1. Block labels unless last down stops a label from inserting into an instance unless it was 
the last code button pressed down. To effectively use this property, 
the coding process must be done sequentially to guarantee that the 
label inserts into the correct code.

2. Block all labels stops the code button from accepting any text label. The instance will never 
have any labels inserted in it.
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EDITING BUTTONS...

Resize a Button

1.  Click and drag on any side or corner of the 
button. 

2.  Drag the button to the desired size.

Note: Graphical buttons cannot be resized. Make them 
the required size in your graphics program of choice, 
then copy and paste them into the window.

Delete a Button 

Click on the button and press DELETE on the keyboard.

Move a Button 

 Click on the button and drag it to the required 
location in the window or use the arrow keys to 
move more precisely.

Note: When using the arrow keys, be sure to close the 
edit button properties window.

Move a Group of Buttons

1.  Press the COMMAND key and select the 
buttons you want to move, or click and drag 
over the group using the lasso bounding box 
to make the selections. 

2.  Click and drag the buttons to the required 
position while holding down the COMMAND 
key.
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EDITING BUTTONS...

Duplicate a Button

1.  To duplicate a button and its properties, highlight the button by clicking on it once.
2.   Press the OPTION key and click and drag the duplicate to another location within the code 

window.
3.  Name the new button. All the properties will be the same as the original except for the hot 

key and the linking. Hot keys can only be used once per code window.
4.  To duplicate a button from one code window to another, press the OPTION key and click and 

drag the duplicate to the new window.
5.  To duplicate a group of selected buttons from one code window to another, press the 

OPTION+COMMAND key and click and drag the group to the new window.

BUTTON LAYERS

Every button created in the code window is on a separate layer. It is sometimes useful to 
overlap buttons or hide them. 

1.  To move a button to the top layer, highlight the button, press CONTROL and the RIGHT 
ARROW key.

2.  To move a button to the bottom layer, highlight the button, press CONTROL and the LEFT 
ARROW key.

3.  To move one layer at a time, press the CONTROL key and press ARROW UP to move the layer 
up 1 level at a time or press CONTROL key and press ARROW DOWN to shift the layer down 
1 level at a time.

 
Alternatively, right click (CONTROL+CLICK) on the button and select the 
action from the drop down menu.

CODE WINDOW TRANSPARENCY

1. To decrease the transparency of the code window, click on the down arrow in the top 
left hand corner of the window next to the capture button.

2. To increase the transparency of the code window, click on the up arrow in the top left 
hand corner of the window next to the capture button.

CODE BUTTON HISTORY
To see a record of the buttons you’ve used, take 
a look at the history line. The most recent button 
activation is shown to the right of the line. A 
triangle pointing down indicates a code button 
being activated. A triangle pointing up indicates 
that code button being turned off.
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SET LEAD AND LAG TIMES

You have complete control over the duration of each instance you code. Using lead and lag times 
means you can program code buttons to automatically add a specific time to the beginning or 
end of an instance when the button is pressed.

Lead Time
Lead Time automatically adds a specific time to the beginning of an instance when it is being 
coded. When you click on the code button to code the instance, the specified lead time is 
added to the time from when the button is pressed down.

For example: You are watching a classroom 
movie and would like to track each time a 
student raises his/her hand. If you assign a five 
second Lead Time to the “Student” code button, 
the instance will appear on the timeline starting 
five seconds before the mouse click. This 
guarantees that the event will be in the instance 
when you review later.

There are Two Types of Lead Time

·  Default lead time applies to all code buttons that you have not programmed with a custom 
lead time. 
· Custom lead time allows you to program a specific lead time to individual buttons.

Program a Default Lead Time

 In the code window, enter the default time you 
want to use in the default time text box.

Program a Custom Lead Time 

1.  In the code window, double click on the code button for which you want to set custom lead 
time. This will open the edit button properties window.

2.  In the edit button window, check the custom lead time box and enter the number of seconds 
of lead time you need.
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SET LEAD AND LAG TIMES...

Lag Time

Lag Time automatically adds a specific time to the end of an instance when it is being coded. 
When you click on the code button to code the instance, Studiocode adds the lag time to the 
end of the Instance.

For example: You are coding a movie and have a six-second lead time and a two-second lag 
time for a code button named “Clapping”. When you see the person “Clapping” and click on the 
button, the instance in the timeline will be eight seconds.

This becomes a fixed Iength instance and requires that you only click on the button once which 
makes the coding process faster and easier.

Customize a Lag Time 

1.  In the code window double click on the code 
button for which you want to set custom lead 
time. This will open the edit button properties 
window.

2.  Check the Lag time box and enter the 
required lag time.

3.  Code Buttons that use a lag time have a 
green diamond identifier.

During coding, if a fixed length instance button is reactivated, the lag time will be reinitialised.

Note: If no lag time is entered, the button will have a toggle action and you must click the button to stop coding. 
Lead and lag times can be set using decimal places to increase frame accurate coding.

Applying properties to multiple buttons
You can apply any property to a group of selected buttons. Select a group of buttons with 
the edit button window open, then right click on the property and select apply to selected 
buttons from the drop down menu. The property will be copied to all the selected buttons. 
All properties can be copied to another button except the hot key and any button links.
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DEFINING HOT KEYS

Assign Hot Keys

1. Click on the Hot Keys box in the edit button properties window.
2.  Press the key or key combination you want to use. Combinations can be configured using 

the modifier keys COMMAND, OPTION, CONTROL, and SHIFT.
3.  Press the modifier keys first, then the character you want to assign.

Note: You can use up to three modifier keys at once plus one character. This allows for over one thousand 
individual hot key combinations. There are some combinations reserved for the system, most of these use 
the COMMAND key.

Change the Hot key Text Color
1. Click on the color chip next to the Show keys check box and select a color from the palette.

Hide Hot Keys
1. Uncheck the Show keys check box to hide the hot key text in the button.

Hot Keys
1.  To keep a tidy window, uncheck the show key box next to the hot key text box in the 

button properties window. Then press the keys button in the code window to show 
them.

2.  Use USB peripheral devices such as remote controls or number keypads to make use 
more flexible, especially if you are running a camera and trying to code at the same 
time.
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BUTTON LINKS

Exclusive Links - Code Button to Code Button
Two or more code buttons can be exclusively linked to each other. This means when one button 
is pressed down and a linked button is pressed, the first button will stop coding and the second 
will start coding. This feature is great for coding quick exchange of dialogue between more than 
one speaker. One click to stop one button and start another.

1.  Open the edit button properties window for a code button.
2.  Click on the Exclusive link drop down menu and select a code button to link to. An arrow will 

appear in the code window to show where to the button is linking.

Exclusive Links - Text Label to Code Button*
A text label can be exclusively linked to a code button, so when it is pressed it can only be 
inserted in the linked code button.

Activation Links - Button to Button*
A button can be linked to another button to activate it. When the linked button is pressed down 
it, it activates any linked buttons. The link line indicates the direction in which the activation 
will occur. Activation links only press buttons down, they will not de-activate a button or toggle 
the button up. Any type of button can activate another button. Chains of activation can extend 
to fire off multiple buttons.

Note: When a text label is linked to multiple code buttons, it is in a chain of exclusivity where the text label will 
describe any of the linked the code buttons.
Click on the link graphics next to the linking drop down menus to display the links for the button. If the Show 
all links is turned off for the button, these links will not  show up until it is turned on. To change the Show links 
option, right click on the links button in the tool bar of the code window and select show all links.
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SAVING CODE WINDOWS
Once you have created all your code buttons, save the code window. You can use this as a 
template for other windows or use it to code any movie. This saves time as you will not have to 
create all the buttons again and you can have as many code windows as you like.

1. Choose File > Save from the main menu 
bar (COMMAND+S)

2. Name the code window.
3. Target where to save the file.
4. If you have saved the code window 

to your desktop, it becomes an icon. 
Double click on the icon to open it.

CREATE A NEW CODE WINDOW USING AN EXISTING ONE 
1. Open the code window you want to use as a template.
2.  Make the required button name changes for the new code window.
3.  Choose File > Save as (COMMAND+SHIFT+S) and give the code window a new name.

Code windows can be moved from computer to computer without any problems just like any 
other type of file. You can share your work and have everyone using the same terminology and 
coding schemes.



Part 3    Studiocode - Operation

26

CAPTURING MOVIES

Capturing a movie means storing the source video material in a digital format on a computer’s 
hard drive.

The following sections demonstrate how to set up a system for capturing video and audio. 
Once the setup is complete and the capture process has been done once, the setting will be 
remembered by the system and the configuration does not need to be done again.

Before You Start 

Before you start capturing a movie, connect your video source to your computer.

1.  If you are taking the video from a VCR or DVD player, you are likely to have a composite 
video connector. Connect this (yellow) connector to the matching connector on the camera 
or convertor box.

2.  If you are taking the video from a professional video recorder/player or a professional video 

feed in a studio situation, use a s-video cable.
3.  If you are using a direct firewire (IEEE-1394) source like a DV camera, connect it directly to 

the computer via the firewire connection.

Set Up for Video Capture

1.  Make sure your capture device (Camera or Analog to Digital convertor box) is connected and 
turned on.

2.  Choose Capture > Clear video and sound preferences from the main menu bar. Next time 
you open a capture window, Studiocode will detect your input device and set the default 
preferences for that device.

3.  Set capture window size. From the main menu bar, choose Capture > Set size of Capture 
Window and select the movie size you require.
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CAPTURING MOVIES... 

Set Up For Sound Capture

1.   Choose Capture > Sound input settings from the main 
menu bar. 

2.  Select your speaker option (On, Off, Off while 
Recording). Ideally, it is best to leave sound off while 
capturing as it can create a feedback loop when a 
camera is attached.

3. In the Compressor drop down menu, 
choose your compression type. In most 
instances, the compressor does not have 
to be changed unless there is a special 
requirement.

4. Select the source for the audio. Typically 
this will be the DV Audio setting unless 
you want to capture audio from an 
external microphone or other type of feed 
like Line In from a radio or CD player.

Start Capture
There are 4 ways to initiate capture.

1. Click on the Capture button in a code window.
A. Open the code window you want to use to code by 

double-clicking on its icon, or open a new one by 
choosing File > New > Code window from the main 
menu bar.

B.  In the code window, click on the Capture button in tool 
bar.

C.  Name the movie and select the location where 
you want to save the movie. When capturing is 
complete click on the End icon in the capture window. 
Studiocode will open the captured movie and timeline. 
You can begin reviewing and editing your coding.

1
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CAPTURING MOVIES...

Note: The background to your Studiocode windows should turn black while you are capturing a movie. This is 
a deliberate behavior to give full focus to the capture and code process. You can jump out of the black screen 
by using the Mac OS X Expose feature.

Stop Capturing a Movie

Click on the End button in the capture window or press COMMAND+. (PERIOD). The 
movie and associated timeline will be saved in a package in the location you targeted 
at the start of the capture process.

2. Choose Capture from the main menu bar or using the short cut keys.
A.  Choose > Open capture window from the main menu 

bar or press COMMAND+R. 
B.  When the movie is previewing correctly in the movie 

preview window, click on the capture button.
C.  Name the movie and select the location where you 

want to save the movie.
D. Click on Start Capture.

2

3. Clicking on the camera icon in the main tool bar.
 A. Click on the camera icon in the main tool bar.
 B.  When the movie is previewing correctly in the movie preview window, click on capture 

icon on the preview window.
 C. Name the movie and select the location you want to save the movie to.
 D. Click on the Start capture button.

3

4. Use the Quickstart capture feature.
 A. Connect the video capture devices.
 B.  Press CONTROL+COMMAND+R to initiate Quickcapture.
 C.  The movie will be saved in the last chosen location with the current date as the 

name.

4
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SYNCHRONIZING SOUND AND VIDEO

 
When using DV capture devices you may occasionally find inaccurate sound and video 
synchronization in captured movies.

Most Common Problems that Occur are:
1. The sound is offset by the same amount throughout the movie file. 
2.  When capturing a long movie, the sound and video synchronization can be good at the 

start of the video, but the further one goes, the more the sound and video synchronization 
becomes a problem. In this case the scale of the video and sound is different and is a 
known problem in Quicktime. 

When Do Synchronization Problems Occur?
The problem of the gradual drift is most likely to occur when the pause/resume button in the 
capture window is not used for extended periods of capture. These buttons start a new video 
file each time they are used, so they can re-synchronize the video and sound. Using the proce-
dures below may not be very useful in this situation, since there are variable length sections of 
video and sound and synchronization in one area may lead to slight miss alignment in others. 
Fortunately, the contracting and expanding procedures work best for movies created when the 
pause/resume button are not used because any drift is constant across a single movie file.

In the main menu bar select Edit > Equalize 
track times. This can only be done after 
the movie capture. However, it is not as 
accurate as equalizing during capture if 
your movie is made from more than one file. 
You can choose to make the equalization 
permanent if your movie is attached to a 
timeline window. This procedure stretches 
or contracts the length of the sound track 
to equal the length of the video track. This 
feature is also useful for resetting the 
tracks when you have nudged, expanded, 
or contracted the sound track and lost a 
synchronization point altogether.

2

In preferences, under General, select 
Equalize video and sound tracks when cap-
turing. This will equalize the length of the 
sound and video tracks during the movie 
capture process (even if the pause button 
is used). In general, the sound track tends 
to be shorter than the video track, so this 
function attempts to keep them the same 
length. This setting is turned on as a de-
fault. 

1
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SYNCHRONIZE SOUND AND VIDEO...

A. Synchronization of audio that is offset the same amount throughout a movie.
 1.  Move the timeline cursor to a section in the movie, near the start of the movie that 

can be used to evaluate the synchronization.
 2. Zoom in the timeline, turn on movie looping and play the timeline movie.
 3.  If the sound is slightly ahead of the video, select Edit > Nudge sound track right 

(CONTROL+OPTION+COMMAND+R). This nudges the sound track one frame to the 
left. Hold down the keys to repeat the nudge continuously.

 4.  If the sound is slightly behind the video, select Edit > Nudge sound track left 
(CONTROL+OPTION+COMMAND+L). This nudges the sound track one frame to the 
right. Hold down the keys to repeat the nudge continuously.

 5.  When you use these features the video and sound will pause, move in the direction 
specified and resume play. If the video is attached to a timeline then Studiocode will 
try to update the movie resource, so the change is permanent. 

 6. Save timeline.

B.  Synchronization of audio that is gradually drifting throughout a movie.
 1. Move the timeline cursor to a point near the end of the movie. 
 2. Zoom in the timeline, turn on movie looping and play the timeline movie. 
 3.  If the sound is slightly behind the video, select Edit > Contract sound track 

(OPTION+COMMAND+L).
 4.  If the sound is slightly ahead the video, select Edit > Expand sound track 

(OPTION+COMMAND+R).
 5.  When you use these features the video and sound will pause, move in the direction 

specified and resume play. If the video is attached to a timeline then Studiocode will 
try to update the movie resource, so the change is permanent. 

 6. Save timeline.

3
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SETTING THE TIMER CAPTURE

Studiocode countdown timer lets you set the time of day to start and finish capturing a movie. 
This is useful when you are not going to be at your computer when the performance is hap-
pening.

Set Capture Start and Finish Times 

1.  Select Capture from the main menu bar 
and choose Countdown Timer.

2.  Set the start and finish times.
3. Click on Begin countdown.

Note: We recommend turning off all energy saving options, so that the computer does not go to sleep while 
this process is in progress. Go to System Preferences, click on the Energy Savings icon and set the computer 
to never go to sleep. The time is taken from the time set on the computer. Set this in the Date & Time panel 
in the System Preferences on the computer.

DELETE A MOVIE

Movie files are generally quite large, so space on your hard drive must be managed and organ-
ized especially if you do not have any external storage.

1. Drag the movie package to the trash can in the dock.
2. Make sure Finder is the active by clicking on the desktop. 
3. Select Finder from the main menu bar and choose Empty Trash.
4.  The Finder shortcut to trash a file is COMMAND+DELETE. To empty the trash, the shortcut 

is SHIFT+COMMAND+DELETE.

When you delete a movie file, we recommend saving the timeline file, so you can link it back 
to the movie. Timelines are very small data files, often no more than 20KB. It is a common 
practice to export the video to a dvd or tape for archiving purposes, then recapture the video 
and match the coded information back to movie. To do this, create a folder, call it Timelines, 
then open a movie, click on the timeline window and select File > Save as. Save the file in the 
Timelines folder. Now, you have your timeline data saved and it can be matched back up to the 
video at a later date.
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RELINKING MOVIES

If you want to re-capture a movie and link it to a saved timeline, you need to re-establish the 
link between the two files.

Link a Re-Captured Movie to a timeline:

1.Open a timeline file.

2. Studiocode will not be able to find the original linked 
movie.

3.Click OK.

4. Use the open dialogue box to locate the movie. This 
links the re-captured movie with the codes.

5. Save the timeline once the link has been established.

Align Instances after Re-Capturing a Movie – Nudge Right Or Left 

When you have re-captured a movie and re-linked it to a timeline, you may find the instances in 
the timeline don’t line up with the relevant parts of the movie.

To correct this:
1. Press SHIFT+COMMAND+R to nudge the instances to the right. This moves all the instances 
one frame to the right. Hold the keys down to repeat the nudge continuously.
2. Press SHIFT+COMMAND+L to nudge the instances to the left. This moves all instances one 
frame to the right. Hold the keys down to repeat the nudge continuously.

Fine Aligning

Find a static part of the movie (for example a jump ball in a basketball game) and use this as a 
reference point when aligning instances in the timeline to the movie.

Adjust Placement of Selected Instances

Instance adjustments can add or subtract time to any selected instances in a timeline. In the 
main menu bar, choose Edit > Instance adjustments.
Mark In, will add or subtract time from the beginning of an instance. 
Mark Out, will add or subtract time from the ending of instance. 
Nudge clips will move the selected instances. Use a minus sign in front of the number to nudge 
clips to the left.   

Click on the adjust button once to make the 
adjustments that are ticked. The adjust but-
ton can be clicked on as many times as re-
quired to make the necessary adjustments. 

I t will continuously apply the adjustments.
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THE TIMELINE

When your timeline and movie are open, the movie is generally displayed in the top of the 
screen and the attached timeline below it.

The Timeline displays:
·  A timeline of your movie represented in hours, minutes, seconds and hundredths of seconds. 
The movie is displayed from the location of the playhead in this timeline. The playhead is the 
small triangle pointing in a downward direction. It can be dragged right or left to move through 
time in the movie.

· Code row names that are populated from code buttons or created manually.

· Instances and where they happen within your movie.

· A tool bar to conveniently access all the tools for editing and presenting your instances.
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CREATE A NEW TIMELINE

Timelines are always created during capture. However, there are times when you will want 
to link a new timeline to the movie so you can code a different aspect, or multiple users are 
coding the same movie and you want to keep the data separated.

1. Choose File > New > Timeline from the main menu bar.
2.  Select the movie you wish to link the new timeline to.
3.  Save the new timeline by pressing COMMAND+S or choose File > Save from the main menu 

bar.

You can now press the code mode button     in your code window to code the movie. Alterna-
tively you can create and modify instances manually.

CODING INSTANCES

Open a code window and movie, then press the Code mode button and the movie should begin 
to play. When you see an event in your movie that you want to code, click on the relevant code 
button or use your preset hot key. The button highlights while it is actively marking and will have 
a red frame if it was the last button closed.

If the button has a lag time, you will see a green bar fill the button until the lag time runs out.

Live Coding
Coding can be done during capture, press the capture icon in the code window tool bar 
to start the process. You can code using the mouse or using hot keys. To save time, we 
suggest using hot keys because you can type while watching the performance, whereas if 
you are mousing you will have to look where you are clicking.
Pausing the movie capture during breaks (such as advertisement breaks) will save 
your computer disk space. Click on the pause button in the capture window or press 
COMMAND+K. Click on the resume button or COMMAND+K to continue capture. Use the 
pause option if you need to fast forward dvds/tapes or interrupt the video signal during the 
movie capture.
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EDITING INSTANCES IN THE TIMELINE

Manually Creating a New Instance
1. Highlight a row by clicking on the code row name or row number.
2.  Position the playhead at the point in the timeline where you want the instance to start or 

end.
3.  Press down OPTION+COMMAND and drag the playhead in the timeline to the required end 

or starting point.
Note: Using a 2 button mouse, you can hold down OPTION+COMMAND+RIGHT CLICK and drag in any row 
to create an instance. Pressing CONTROL and clicking activates the right mouse click. So, you can press 
CONTROL+OPTION+COMMAND and click & drag in any row to create an instance too.

Adjust the Length of an Instance

Instance Edit
1. Select an instance in the timeline.
2. Choose Edit > Instance edit from the main menu bar or 
press CONTROL+E. A movie window will open with left & right 
arrows in each of its upper corners.

3. Press the arrows in the direction required to lengthen or shorten the clip. The upper left 
arrows will adjust the start of the instance and the upper right arrows will adjust the end. 
The instance will update in the timeline as adjustments are made.

Click and Drag
Press OPTION+COMMAND, position the mouse cursor over the 
beginning or ending of an instance. When the cursor changes to 
arrows pointing to the left & right, click and drag the instance to the 
required length.

1

2

Trim
The trim feature can be used to quickly adjust start and end times for a row of existing 
instances. It is a sequential process: trim start > end > start > end > start and so on. The 
process starts by setting the first point, if the playhead is set before the midpoint of the 
instance, it will begin by adjusting the start time to the playhead location. When it is set 
beyond the midpoint it will adjust the end time. Once the adjustment is made, it will jump 
to the end time of the selected instance or the start of the next instance.
1.  Highlight the instance and position the playhead to the required start time of the 

instance, not beyond the midpoint or the end point will be trimmed.
2.  Press CONTROL+T, the start time will be adjusted and the playhead will jump to the end 

time of the instance.
3.  Position the playhead to where the adjustment of the end point should be made and  

press CONTROL +T. The playhead will jump to the next instance in the row.
4.  Position the playhead for the new start time and press CONTROL+T. The playhead will 

jump to the end of the instance. Repeat, until all adjustments are made.

3
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EDITING INSTANCES IN THE TIMELINE...

Adjust the Length of an Instance...

Delete an Instance

Highlight the instance by clicking on it, then press the DELETE key.

Copy an Instance from One Row to Another

1. Press OPTION and click & drag on the instance you want to copy.
2. Drag it to the new row.

Move an Instance from One Row to Another

1.  Copy the instance to the new row by pressing the OPTION and click & drag the instance to 
the new row.

2. Delete the original instance by selecting it and pressing the DELETE key.

Instance Adjustments
1.  Select an instance or range of instances by 

clicking and dragging over the instances in 
the timeline.

2.  Select Edit > Instance adjustments... from the 
main menu bar.

3.  Input the time in seconds for the amount to be 
adjusted. 

4.  Select whether the time will be added or subtracted from the instance marks.
5.  Check the mark in or mark out check boxes to apply the adjustments to one or both.
6.  Click the adjust button.

Note: If you make a mistake, simply make the opposite adjustment. If you added 3 seconds to the mark 
in time of an instance, change the add to a subtract and adjust it back. Adjustments can be made up to 
hundredths of seconds, so this can make some very finite adjustments to an instance, hardly possible 
with a mouse.

4
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WORKING WITH CODE ROWS

Move a Row
Click and drag from the row number in the timeline.

Select Multiple Rows
1.  Press COMMAND and click on the row numbers  you want to select.
2.  To select a range of rows, select the top row of the desired range, then select the bottom row 

while holding down SHIFT.

Duplicate a Row
1.  Press CONTROL and click (RIGHT CLICK) on the row number you want to 

duplicate.
2. Select Duplicate selected rows from the drop down menu.

Delete a Row
1.  Press CONTROL and click (RIGHT CLICK) on the row number  you want to delete.
2. Select Delete selected rows from the drop down menu.

Edit Code Row Names
1.  Press CONTROL and click (RIGHT CLICK) on the row number you want to edit.
2.  Select Edit row from the drop down menu. This opens the row properties strip.
2. Type in the new name in the text area.
3.  Use the arrow keys to move up and down rows or press ENTER to move down rows and 

SHIFT+ENTER to move up rows.
4. Press the ESC key when changes are complete to close the strip.

Change Code Name Colors
1.  Press CONTROL and click (RIGHT CLICK) on the row number you want to edit.
2.  Select Edit row from the drop down menu.
3.  Click on the color chip to the left of the row name.
4. Drag into the color palette and choose a new color.
5.  Use the arrow keys to move up and down rows or press ENTER to move down rows and 

SHIFT+ENTER to move up rows.
6. Press the ESC key when changes are complete to close the strip.
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WORKING WITH CODE ROWS...

Add a New Blank Row to the Timeline
 Choose Rows > Add row from the main menu bar. The new row will 
be created below the selected row in the timeline. Alternatively, 
you can press the New row icon in the timeline tool bar or press 
COMMAND+N.

Create a New Row from Selected Instances using New Row +
 Select the instances that you wish to include in a new row, press COMMAND and select 
the instances one by one or click and drag in the timeline to select a group of instances. 
You can also select rows of instances too. With the instances selected, click on the New 
row + icon in the timeline tool bar. 

Create a Combination of Rows
1.  Choose Rows > Create new row from the main menu bar. This opens the Add row window 

where you can select 2 rows to create a new one using different time intersection options.
2.  Name the new row and select where in the timeline to insert it.
3.  Click the Combine rows radio button to form 

new row.
4.  In row A, choose the first row you want to 

use.
5.  Choose the operation that will apply to the 

combination of rows. The type of operation 
is illustrated in the box at the left of the 
window.

6. In row B, choose the second row you want to 
use and click the Create row button.

AND, OR, or NOT can be used as operators. AND will create instances where A and B overlap. OR 
will create instances from both rows combining where overlaps occur. NOT creates instances 
where A does not exist.

Create New Row Hints
1. For fast alternating dialogue between two people, code one person’s half of the 
conversation, then use the NOT operator, to create the second person’s timeline row.
2. When you want to use more than two rows, create a new row from the first 2 rows, then 
create another row from that row using it as row A and the third row as row B. Repeat this 
again and again to drill down further.
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SORTING CODE ROWS

Rows can be sorted in a variety of ways, manual dragging up and down being the most common. 
However, using name and color can automate the process and make organizing the timeline 
a lot quicker.

Sort Rows by Name
Choose Rows > Sort rows by name from the main menu bar. All rows will sort by alphabetical 
order.

Sort Rows by Color
Choose Rows > Sort rows by color from the main menu bar. Colors are sorted in order of the 
palette from left to right descending from lighter to darker. The color palette has 600 colors 
and each color has an (X,Y) coordinate. White in the upper left most corner (1,20) and the 
darkest red in the lower right most corner (30,1) define the sorting pattern from left to right, 
top to bottom.

Sort Rows by Color then by Name
Choose Rows > Sort rows by color then by name from the main menu bar. All rows will sort by 
color and then within each color sort by name.

Sort Rows by Number of Instances
Choose Rows > Sort rows by number of instances from the main menu bar. All rows will sort 
according to how many instances are in each row. The row with the most amount of instances 
will move to the first row. The row with the second most amount of instances will move to the 
second row and so on.

Sort Rows in Reverse Order
Choose Rows > Sort rows in reverse order from the main menu bar. All rows will arrange in 
reverse order from top to bottom to bottom to top.

Code Button Colors and Sorting
A great way to make organizing the timeline a quick job is to consider your button colors 
and how they will affect sorting. Use colors with the X coordinates from 1-30 and same 
Y coordinates for similar code buttons categories. Then, use descending Y coordinates 
from 1-20 for grouping different categories. The code window will look like a rainbow, but 
you can quickly sort the timeline using the Sort rows by color feature. So, Teacher action 
buttons might range from (1,16) to (30,16) and Student action buttons might range from 
(1,7) to (30,7). In this example, the Teacher actions will sort to the top of the timeline and 
the Student actions will sort below them.
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MOVIE PLAYBACK
Playing a movie is easy, you can go to any part of the movie whenever you like with a click of the 
mouse. You’ll be there instantly, no need to fast forward or rewind.

Playing any Movie

There are five ways to play a movie:

Pause any Movie 

There are five ways to pause a movie:

Note: With a roller mouse place your cursor over any movie window and roll up or down to play or pause movie 
playback. With two finger scrolling turned on, put two fingers on the track pad and push fingers up to play and 
pull fingers down to pause movie.
Change the playback speed of a movie by holding down COMMAND, place the mouse over the window and two 
finger scroll on the track pad or use the wheel mouse.
The state of play, whether the movie is paused or playing, will re-engage after any rewind or fast forward 
action. 

Press the UP 
ARROW on 
the keyboard.

Click on 
the movie 
window.

Click on the 
pause icon    
on the tool 
bar.

Press the 
SPACE 
BAR on the 
keyboard.

Press the 
DOWN 
ARROW on 
the keyboard

Press 
CONTROL+K 
on the 
keyboard.

321 4 5

Double click 
on the movie 
window.

Click on the 
play icon 
on the main 
tool bar.

Press the 
SPACE 
BAR on the 
keyboard

Press 
CONTROL+L 
on the 
keyboard.

321 4 5
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MOVIE PLAYBACK...

View the Movie Frame by Frame 

There are two ways to view a movie frame by frame:

Play a Movie in Slow or Fast Motion

1.  The tool bar has a speed slider, click and drag the sliding indicator to the speed you 
require.    All movies will be played at this speed.

Go to a Specific Part of the Movie.

There are three ways to go to a specific part of the movie:

MOVIE PLAYBACK KEYBOARD CONTROL

Once a movie is created or linked to a timeline, you can use many key combinations to play it 
at different speeds.

· UP ARROW plays the movie.
· DOWN ARROW stops the movie.
·  RIGHT ARROW moves the movie forwards by 1/10 sec frame by frame. Hold it down for 
continuous slow motion movement forward.
·  LEFT ARROW moves the movie backwards by 1/10 sec frame by frame. Hold it down for a 
smooth rewind action.
·  HOME moves the playhead to the beginning of the movie.
·  END moves the playhead to the end of the movie.
Pressing the modifier keys; COMMAND, SHIFT, OPTION, & CONTROL plus LEFT OR RIGHT 
ARROW will move the playhead at different increasing speeds. Another way to move the 
playhead around is press CONTROL+L, CONTROL+K, or CONTROL+J. CONTROL+L will play the 
video forward, each time it is pressed the movie will play faster. CONTROL+J works the same 
way, but in reverse. CONTROL+K will pause the video.

 Press the LEFT or RIGHT ARROW keys to 
view the movie frame by frame.

Click on the Step Forward/Back Button on 
the main tool bar.

21

Use the Fast Forward or 
Fast Rewind Buttons on 
the main tool bar.

Drag the 
playhead in the 
timeline to the 
required point 
in the movie.

Press the RIGHT or LEFT 
ARROW keys to move 
the playhead though the 
movie.

321
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CREATING INSTANCE MOVIES

You can create an instance movie in the timeline from:
· A single instance.
· All instances in a single row chronologically.
· Selected instances across multiple rows chronologically (Merge rows).
· Sequential rows in order of row number and the selected rows (Sequential rows).
· Selection order in a single row or across multiple rows (Selection order).

Play a Single Instance 
1. Double click on the instance in the timeline or select an instance and press the Make 
movie button in the timeline tool bar.

Play All Instances in a Single Row
1. Select the row of instances by clicking on the row number. 
2.  Click on the Make movie button in the timeline tool bar. All instances in the row will play in 

chronological order. Alternatively, after selecting the instances, press OPTION+COMMAND+M 
on the keyboard to create the instance movie.

To make it even easier, double click on the row number and an instance movie will be created 
from all the instances in the row.

Merge Rows, Sequential Rows, and Selection Order
There are 3 different ways to play instances across multiple rows by changing the make movie 
method in the timeline. By default, Merge rows is selected. To change, click on the square 
button in the upper left corner of the timeline window. Remember to press the Make movie 
button or use the shortcut OPTION+COMMAND+M.

Merge Rows
Merge row creates instance movies in chronological order of the timeline. When multiple 
instances are selected in different rows, the merge rows feature will merge the instances and 
create chapter markers where instances overlap.
1.  Hold down COMMAND to select multiple rows. Select the row of instances by clicking on the 

row number.
2.  Click on the Make movie button on the timeline tool bar. The instances will play in 

chronological order, alternatively use the shortcut OPTION+COMMAND+M.
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CREATING INSTANCE MOVIES...

Sequential Rows
Sequential rows creates instance movies in row order of the timeline for all selected instances. 
When multiple instances are selected in different rows, the sequential rows feature will start 
from the lowest row number and proceed to the highest row number. All instances in each row 
will be played in chronological order.
1.  Organize the timeline rows by dragging on the row number.
2.  Select the Sequential rows feature in the timeline.
3.  Hold down the COMMAND key and click on the row number to select multiple rows.
4.  Click on the Make movie button on the timeline tool bar. The instances will play according 

to their row order.

Selection Order
Selection order creates instance movies in the order that instances are selected in the 
timeline.

1.  Select the Selection order feature in the timeline.
2.  Hold down the COMMAND key and click on the instances in the order 

you want them to play in the instance movie. As each instance is 
selected, it is labeled with a number [1], [2], [3]...

3.  Click on the Make movie button on the timeline tool bar. The instances 
will play according to their selected order.

USING INSTANCE MOVIES CHAPTER MARKERS

When an instance movie is created from multiple instances in a timeline, each instance in the 
instance movie is marked by a chapter marker. There are two ways to jump through the chapter 
markers.
1.  In the instance movie, press the TAB key to 

move forward to the next chapter marker. 
SHIFT+TAB moves backwards to the previous 
chapter marker.

2.  Click on the chapter menu in the bottom right 
corner of the instance movie. A drop down list 
of chapter markings will appear. Click on the 
instance you want to view.

NOTE: A similar feature is in the timeline. Select a 
row of instances, press CONTROL+TAB to jump to the 
beginning of each instance. SHIFT+CONTROL+TAB will 
move to the previous instances.
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PRESENTING INSTANCE MOVIES
Any timeline movie or instance movie can be presented in full screen.

Present a Movie in Full Screen
There are three ways to present a movie in full screen:

Stop Presenting a Movie in Full Screen
To stop presenting a movie in full screen press the ESC key on the keyboard.

Loop Instance Playback
Looping an instance repeats it continuously
1. On the main tool bar, select the Loop button. It will change from     to     .
2. Play the movie.
NOTE: When the looping feature is turned on, the timeline movie will loop also. If the timeline is zoomed in, it 
will loop within the zoomed range.

Adjust the Movie Volume 
· On the main tool bar, click on the Volume button.     Drag the control button to 
 the desired volume.
·  In an instance movie, click on the speaker icon in the bottom left of the movie window. Drag 
the control button to the desired volume.
· Use the Function keys on the keyboard to increase or decrease volume.

Resize Movie Window
1.  Select the movie window.
2.  Choose Reduce movie size or Increase movie size from the Windows menu in the main menu 

bar, or use the shortcut keys, SHIFT+COMMAND+, or SHIFT+COMMAND+..
Note: A timeline movie has 2 rectangle icons in the bottom left of the window. These can be clicked to change 
the movie size also. If CONTROL is held down when these are clicked, the timeline and movie will arrange 
automatically.

Select Windows from 
the main menu bar and 
choose Present movie.

On the main tool bar, click 
on Present movie button. 
This will present the 
movie full screen.

To play the movie in full 
screen presentation 
mode, select the movie 
window, and press the 
COMMAND+M keys on the 
keyboard.

321
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EDITING INSTANCE MOVIES
Instance movies can be edited using delete, cut, copy and paste or drag & drop features. By 
selecting a segment of an instance movie, the segment can be deleted or copied and pasted 
into another instance movie. NOTE: Editing instance movies does not edit the timeline.

Delete a Segment in an Instance Movie.
1.  Select a segment in the instance by holding SHIFT and dragging the playhead in the instance 

movie. As the playhead is dragged, the timeline of the instance movie will fill in with a darker 
grey color. The darker grey area is the selected portion.

2.  Press CONTROL+COMMAND+DELETE to clear the selected segment. Or choose Delete movie 
segment from the Edit menu in the main menu bar. An instance movie for presentation can 
be assembled from many different segments of other instance movies.

Copy and Paste Instance Movie Segments
When an instance movie is created from a timeline, the entire length of the movie is selected 
by default. If you move the playhead in the instance movie, you will lose the selection. To 
reselect the whole instance, move the playhead to the beginning, hold down SHIFT, and drag 
the playhead the entire length of the instance movie.
1.  Open two instance movies from a timeline.
2.  In the second instance movie, press CONTROL+COMMAND+C. This will copy the selection 

in the instance movie. If the playhead was not moved, it will copy the entire length of 
the instance movie. If it was moved, it will only copy the frame that is currently being 
displayed.

3.  In the first instance movie, move the playhead to the end and press  CONTROL+COMMAND+V. 
This will paste the second instance movie segment at the end of the first instance movie.

4.  Repeat this process to continue adding segments to the end of the instance movie.
Note: Segments can be pasted into any part of an instance movie. Position the playhead where you want the 
segment to be inserted and when you copy and paste, it will be inserted at that point.

Drag and Drop Instance Movie Segments
To simplify the process, you can drag and drop movie segments from one instance movie to 
another.
1.  Open two instance movies from a timeline.

2.  Position the playhead in the beginning of the first 
instance.

3.  Click and drag from the middle of the movie frame of 
the second instance and drop into the first instance 
movie. The first instance movie will highlight with 
zebra stripes around the movie frame.

4.  The segment will insert at the beginning of the first 
instance.
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COMBINING INSTANCE MOVIES
A simple way to combine instances in a specific order is to use the Combine instance movie 
feature. This feature creates a new instance movie from all open instance movies in the order 
that they are layered on the screen.
1.  Open 2 or more instance movies in reverse order for which you want them combined. Create 

the second instance first, then the first one. This will layer them correctly without having to 
click on the movie windows to layer them.

2.  Choose Windows > Combine instance movies in main menu bar. A third movie window will 
open that will have both instances in the movie in the order that they were layered on the 
screen.

NOTE: To add another instance to the beginning or end of the new combined movie, close the first 2 instance 
movies used to create the newly combined one. Do not close the newly combined instance movie. Open 
another instance from the timeline, layer it in front or behind the open combined instance movie, then choose 
Combine instance movies. If the new instance was in front of the combined one, it will be added to the 
beginning, if it was behind, it will be added to the end. Repeat this process to assemble a full length movie 
for presentation.

MOVIE ORGANIZER
The Movie Organizer is a presentation creation tool designed to organize and edit instances. 
Instances can be dragged around to change the order or they can be trimmed using the 
instance edit window. A movie organizer can be saved and reopened for future presentation 
or editing. A movie organizer window can be opened in two ways. The first is to choose File 
> New > Movie Organizer. The second is to select an instance or multiple instances and 
press the Organizer button in the timeline tool bar. This button has a short cut too, press 
COMMAND+OPTION+V to paste into an organizer. This will open a new movie organizer if one 
is not already open. If an organizer is open, then the instances will be pasted in the open 
movie organizer window.

Paste Instances Into The Organizer
1. Click, drag and drop selected instances 

into the movie organizer.
2. Select an instance or multiple instances, 

click on the organizer button in the tool bar 
or press COMMAND+OPTION+V.

3. To place an entire row into the movie 
organizer, select the row by clicking on the 
row name, press COMMAND+OPTION+V. 
Hold down COMMAND and click on 
multiple row names to select multiple rows 
of instances.
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MOVIE ORGANIZER

Playing Instances In The Movie Organizer
·  All Instances can be played by clicking on the Make Movie Button at the top of the movie 
organizer.
·  All Instances associated with a row can be played by double clicking on the row name.
·  An individual instance can be played by double clicking on it in the movie organizer window.

Make Movie Options In The Movie Organizer
 By selecting Titles, the row name will appear as a title frame before the corresponding in-

stances for the row are played. The number of instances are 
displayed diagonally with thumbnails in the title.
By selecting Static text, each instance’s associated text de-
scriptors will be displayed in a static title before each instance. 
A static movie will play for the default duration of text movies 
set in the Studiocode preferences.
By selecting Instance notes, a text track will be displayed at 
the bottom of the instance movie with the instance notes 
showing in the text track.

Changing Row Name In Movie Organizer
·  Row characteristics such as row name and color can be edited by right clicking on the row 
name in the movie organizer and selecting edit row from the popup menu.
·  Changing the row name for a title row will change the text in the title that is created.

Editing Instances And Movies In The Movie Organizer
·  To move an instance to another row, click and drag instance to desired location.
·  To create a new row click on the new row button in the movie organizer tool bar.
·  To include or exclude rows from operations, select or deselect the tick box.
·  To edit the in or the out point of an instance, select the instance and press the CONTROL+E 
keys. This will open the instance edit window. Make changes by pressing the arrows in the 
upper corners of the instance edit window.
·  To delete any instance, highlight the instance and press the DELETE key.
·  To drag and drop instances between movie organizer windows, select multiple instances in a 
movie organizer, hold down COMMAND+OPTION, click and drag from the selected instances 
and drop into another movie organizer window.
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MOVIE ORGANIZER

Paste A Picture From The Clipboard Into The Movie Organizer 
1.  Click on new picture button in the movie organizer tool bar, this will create a new picture row 

in your Movie Organizer.
2.  In the new row click on the white box and paste in your picture.
3.  Drag the picture row to the row above the clips you want it to show before.
Note: When a picture is pasted into the movie organizer it is scaled to the full movie size. Drag the bottom 
of any picture to resize the row. Pressing SHIFT+COMMAND and dragging the bottom of any picture will 
simultaneously alter the size of all picture rows.

Changing Labels
The label tree pop menu can be accessed by right clicking on an instance. The label tree pop 
menu is created from all the labels found in the movie organizer window. If new labels need 
to be added, open a new label tree window, add the labels to the new window, then right click 
on the instances to add the new label or any timeline label tree or previously saved label tree 
window can be opened and used.

Adding Notes
Instance notes can be added to individual instances. Select the instance and press the Notes 
button in the movie organizer tool bar. Type the text into the notes window. Close the window to 
save the note or select another instance to add notes to.

Save A Movie Organizer
Choose File > Save, File > Save as..., or press COMMAND+S. The Movie Organizer will 
be saved as a file with this icon.

Database Instances from a Movie Organizer*
Select the instances you want to export to a database and click on the database but-
ton in the movie organizer tool bar.

INSTANCE SEQUENCER
The instance sequencer presents a list of the instances within a row of a movie organizer. 
The order of instances can be arranged by dragging the rows up or down. Instance labels and 
duration can also be edited.

Open the instance sequencer for a row by double clicking on the yellow sequencer icon 
to the left of the row name in the movie organizer.
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INSTANCE SEQUENCER

Play and Edit Instances in the Instance Sequencer
Double clicking on a row will open the edit instance window, the instance can be viewed or 
edited. To play or edit another row, single click on the row and the edit instance window will 
update the changes in the last row and move to the new selection. Close the edit instance 
window by clicking on the red button in upper left corner of the window.

Delete Instances from the Instance Sequencer
Select a row and press the DELETE key.

Editing Labels in the Instance Sequencer
The labels popup menu can be accessed by right clicking on a row. The labels in the pop menu 
that are displayed will only be those labels from the movie organizer row. Open a saved label 
tree to add new ones or open the timeline and press the labels button.
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VIEWING TEXT LABELS IN AN INSTANCE
Text labels within an instance can be viewed in two ways.

EDITING TEXT LABELS USING THE LABELS TREE POP UP MENU

The labels tree is a pop up menu system used to add or remove text labels 
for an instance in the timeline or the movie organizer. The labels tree pop 
up menu is auto generated from the text labels in a code window or can be 
created manually using the Labels Tree window. When code mode is activated 
in the code window, the labels tree pop up menu is saved into the timeline 
and can be accessed by right clicking on an instance.

To Add or Remove a Text Label in an Instance 
There are 2 ways to add or remove labels from an instance.

Open the Edit labels window, COMMAND+E, 
then select an instance.

To add a label press the new label 
button, then double click on the new 
untitled text label row and add the 
text.
To remove a label, select the row, 
then press the scissors button and 
it will dissappear.

Leave the window open and click on 
instances to quickly edit or view labels.

Hover the mouse cursor over the instance 
in the timeline, the text labels will appear in 
the strip above the playhead bar.

1
Open the Edit labels window by selecting 
Edit instance labels... from the Edit menu 
in main menu bar. Click on an instance 
and the labels will appear in the Edit labels 
window.

2

Right click on an 
instance, the menu 
will open. Hover over 
a text label and press 

COMMAND to add a label, a blue diamond 
will appear next to the label. To remove 
a label, hover over the text label, press 
SHIFT+OPTION+COMMAND.
To add or remove multiple copies of 
the same label, press COMMAND or 
SHIFT+OPTION+COMMAND multiple times. 
If the menu is clicked on, it will disappear 
and add the label that was clicked on.

21
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THE LABELS TREE WINDOW
The Labels Tree window controls the pop up menu that appears when an instance is right 
clicked. All the labels found in the instances in the timeline are shown in cells of this spreadsheet 
style window.

The pop up menu will appear as the rows are ordered in the 
window. Labels can be sorted alphabetically in ascending or 
descending order. The labels tree window can configure the 
pop up menu layout to extend horizontally, so labels can be 
structured in logical and easy to navigate branches. A labels tree 
can be saved as a file and used similarly to a code window. 
Many labels trees can be opened at one time. It is the front 
most label tree window that will appear as the pop up menu 
when an instance is right clicked on. This is useful when coding 
enitirely different aspects of an event and can help avoid long 
lists of labels that make it difficult and time consuming to find a 
specific label.

A default labels tree window is created for the timeline from using a code window in code 
mode. If multiple code windows are used, all the labels from each window will be added to the 
default labels tree in the timeline.

Accessing and Creating a Labels Tree
There are many ways to access a label tree. The most common way is to press the labels button 
in the timeline window. This will open a labels tree with the labels that were used for coding 

the timeline. Once opened this window can be edited and the changes will be saved 
in the timeline. The window can also be saved like a code window and used to label 
other timelines and the new label tree data will be saved in those timelines. Opening 

an existing labels tree is a good place to start when building separate label trees for various 
coding work flows.
Labels trees can be created from scratch too. Select File > New > Label Tree. Then add a label 
in a cell of each row in the first column of the window. When this window is the front most labels 
tree window, it will be used to create the pop up menu that appears when an instance is right 
clicked. Save this window by pressing COMMAND+S.

In Studiocode, a labels tree can be created by right clicking on the Label mode button in a code window. Select 
export labels from the pop up menu and all the labels will be exported into a new label tree. The label button 
color will be exported too making it easier to find label sections in the window.

Adding a New Text Label to The Labels Tree 
Press the new row button in the tool bar of the label tree window. This will create a new row 
under the currently selected row or at the bottom of the window if no cells are selected.

Deleting a Text Label in the Labels Tree
Right click on the row number and select delete row from the pop up menu.

Changing a Label
Click in the cell and edit the text.
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THE LABELS TREE WINDOW

Creating Branches for the Labels Tree Popup Menu
Adding columns to the labels tree will create branches for the the popup menu that appears 
when you right click on an instance to edit the labels in the instance. Creating branches spreads 
the lists of labels out horizontally and groups them, so labels can be more easily navigated and 
found.
The root of the menu is the first column in the labels tree window. The second column creates 
a branch from the root and subsequent columns create sub-branches of the branches. The 
labels tree can have as many columns (branches) as is required. A branch ends when the last 
column and rows of that column end.

Here is how to create a simple one branch level menu.
1.  Create a new labels tree window. File > New > Labels tree.
2.  Add 1 column and 9 rows by pressing the add rows and 

add columns button in the tool bar.
3.  Add the name for the first branch in cell (1,1). Then, 

add labels in cells (2,1), (2,2), and (2,3). This creates 
the first branch with 3 labels as options in the popup 
menu.

4.  Add the name for the second branch in cell (1,4). 
Adding text into this cell ends the previous branch and 
starts a new one. Then, add labels in the cells (2,4), 
(2,5), and (2,6). This creates the second branch with 3 
labels as options in the popup menu.

5.  Add the name for the third branch in cell (1,7). Then, 
add labels in the cells (2,7), (2,8), and (2,9). Adding 
text into this cell ends the previous branch and starts a 
new one. This creates the third branch with 3 labels as 
options in the popup menu.

6.  Save the labels tree, so it can be re-opened and used again to label instances in a 
timeline.

7.  Test the labels tree by opening a timeline and right 
clicking on an instance. If the labels tree is the top 
most label tree window, the popup menu will appear as 
it has been structured.

Use multiple Labels Tree Windows
Create multiple labels tree windows where each window has a specific set of label 
information in it. (Name the windows as to their purpose and the information contained) 
Open all the labels tree windows at once, press the small button in the upper right corner 
of each window, this will hide the window, leaving the window bar only showing. Click on the 
window bar for the labels tree that will 
display in the popup menu when an instance is right
clicked on. The top most label tree window will display in the popup menu.
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TEXT TRACKS

Notes can be added directly to an instance in the timeline. Text tracks are designed to add in-
formation that speaks to those viewing the movie or as a method to record special information 
regarding the instance. The Text track will appear at the bottom of an instance movie when Text 
trakcs is checked in the timeline tool bar.

Adding a Text track
1.  Select the instance in the timeline to add text to in the 

timeline.
2.  Open the Edit text track window by pressing on the 

Note button in the timeline tool bar.
3.  Add the text in the Edit instance window. When all the text 

is added, click on the red button to close the window and 
save the note.

The Edit instance window maybe be left open to easily add notes to an instance. Select any 
instance and the edit instance window will change to that instance. The text will be saved in 
the instance when the next instance is selected after adding the text. This makes adding notes 
a quick job and saves on mouse clicks.

Viewing Text tracks in a movie
Enable Text tracks in the timeline by checking the Text tracks check box.

When a movie is made from instances in the timeline, a Text 
track will appear at the bottom of the movie window.

Setting the amount of lines of text displayed
Click on the lines drop down menu in the timeline. 
Select the amount of lines of text that will appear at 
the bottom of movies. If there is a lot of text that is 
required to display, set this to match the lines required 
to display the text. Otherwise, the text track text will 
scroll the duration of the movie.

TIMELINE NOTE

A note about the timeline can be added using the 
timeline note window. Timeline note can be used in 
many ways, the note could be about the game video and conditions, official statistics can be 
pasted here, or information regarding the file itself like credits for those who coded.
The timeline note window is accessed by pressing 
COMMAND+OPTION+E or selecting Edit > Edit 
timeline note in the main menu bar. Add the 
information to the Timeline note window, close the 
window to save the information in the timeline.
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SORTER WINDOW

The sorter window is a spreadsheet-style organizing and analysis tool, a powerful combination 
of the movie organizer, instance sequencer and statistical window. In the sorter window, 
instances can be trimmed, labels can be edited, and instance notes added. Rows can be 
automatically sorted by movie time references, alpha-numerically, or frequency of occurrence 
according to grouped labels. And final presentations can be arranged with picture rows created 
from the drawing window.

Like the movie organizer, rows are created in the sorter window by pasting instances from a 
timeline. Select instances in a timeline and press the sorter button in the timeline tool 
bar. A new sorter window will open automatically if one is not open. If a sorter window 
is open, the instances will be pasted below the last row in the window.

An individual row can be moved vertically up or down to change the order by clicking and 
dragging from the row number. Multiple rows can be selected by holding down COMMAND or 
SHIFT, then moved as a group by clicking and dragging with these keys pressed down.

During the analysis process, a higher level of detail can be added in the sorter window. Any 
changes made to an instance in the sorter window can be synchronized with the original 
timeline.
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SORTER WINDOW*

Sorter Window Tool Bar

Print sends the sorter window to a printer or .pdf file.

Column inserts a new column after the selected one or creates a new 
one as the last column.

Row inserts a new row after the selected one or creates a new one as 
the last row.

Bold, Italic, Color, and Size change the appearance of the selected 
text.

Movie creates an instance movie for all rows in the sorter window.

Edit movie opens the edit instance movie window. This is used to trim 
the start and end points for the row.

Synchronize sends time, label, and instance note changes for selected 
rows in the sorter to the original instances in the timeline.

Nest sort, when checked before sorting a column, subsequent column 
sorts will be sorted keeping the previous sort in tact.

Position re-arranges sorter, timeline, edit instance movie windows to 
help window layout.

Database send selected rows to a database.
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SORTER WINDOW*

Sorter Window Column Settings Bar

Clicking on the icons in the column settings bar of the sorter window will turn on and off the 
settings for locking content, searching, and text overlay.

 Unlocked Column  Cells in column can be edited.

 Locked Column  Cells in column cannot be edited.

 Searchable Column Cells in column will be searched with CTRL+F.

 Unsearchable Column Cells in column will not be searched with CTRL+F.

 Time Reference Column

 Picture Column

 Code Column  Text overlay will be displayed.

 Code Column  Text overlay will not be displayed.

 Text Label Column   Text overlay will be displayed.

 Text Label Column  Text overlay will not be displayed.

 Grouped Text Label Column Text overlay will be displayed.

 Grouped Text Label Column Text overlay will not be displayed.

 Instance Note Column Instance note text track will be displayed.

 Instance Note Column Instance note text track will not be displayed.

Sorter Window Column Type Setting
A column type is set by right clicking on the column setting bar above a column. There are  8 
column types.

Time Reference Column
Time reference column displays the start time, duration, and 
timeline origin for the instance in the row.

Picture Column
An image can be pasted into this column and it will be presented 
as a title in a made movie. A picture can be created in the drawing 
window and pasted using the paste to sorter button in the drawing 
window.

*Studiocode feature only.
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SORTER WINDOW*

Code Column
The name of the code row from which the row was pasted is displayed in this 
column. The text in this column can be edited for overlay text purposes, but 
the code row name cannot be synchronized back to the original timeline.

Instance Number Column
The instance number from the original timeline row is displayed in this column. This column 

can be helpful for sorting purposes in the sorter window or referencing 
instances in the original timeline.

Instance Note Column
The instance note column displays any instance notes that have been entered into the 

instance. Notes can be edited or added in this column. This is an easy way 
to add instance notes, copy and paste can be used to add the same notes to 
multiple instances quickly.

Text Label Column
The text label column displays any ungrouped text labels that have been coded in the 

instance using text label buttons. If text label buttons have not been 
designated in groups the column header will read “No group”. Each text 
label will be displayed on a separate line. To add new labels, enter each 
label on a new line.

Group Text Label Column
The group text label column displays grouped text labels that have been coded in the 

instance. The column header name represents the group name and the 
grouped text labels will fall separately under the associated group columns. 
This column type is best for nested sorting.

Default Column
The default column is generally not used in the sorter window. But, can be used as a general 

note column or column separator.

*Studiocode feature only.
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SORTER WINDOW*

Exporting Instances to a Sorter Window
Any group of selected instances or single instance can be exported to a sorter window. Select 
the instances in the timeline, then press the sorter button in the timeline tool bar. If a sorter 
window is open the instances will be pasted below that last row of the window. If a sorter 
window is not open a new one will be created automatically with the instances. When multiple 
instances are exported at once, they will be pasted in the window chronologically. If the selection 
is across multiple rows, each row will be pasted in their respective sections in the sorter.

Creating an Instance Movie in the Sorter
Double click on the row number or time reference cell for a row. To make a movie of multiple 

rows, select the rows using COMMAND or SHIFT and press the movie button in the 
sorter tool bar. If no rows are selected, the movie button will create an instance movie 
from all rows.

Viewing and Editing Instances
The edit instance movie can be used to view and trim instance rows in the sorter window. 

Click in a cell and press on the edit movie button in the sorter window tool bar to 
open the instance edit movie window. The start and end time of the instance can be 
edited using the arrow buttons in the corners of the edit instance movie. To change 
the instance being displayed in the movie window, click in any cell of a different row. 
The edit instance movie will update as the cells are clicked in different rows. Turn 
on movie looping mode to make the make the movie play continuously, saving a few 
keystrokes or mouse clicks.

Using the Keyboard
To move around in the sorter window with the keyboard, begin by selecting a cell with the 
mouse. Press the TAB key to move to the next cell to the right of the active cell. When the last 
cell in the row is reached it will wrap to the next row down in the first cell. Pressing SHIFT+TAB 
will move in the reverse direction. Alternatively, hold down CTRL and use the arrow keys to 
move up, down, right, and left around the cells.

*Studiocode feature only.

Editing Labels with the Label Tree Popup
Labels and instance notes can be edited, added, or removed in a cell. Click in the cell 
change the text, input new text, or delete the text. When adding text labels, care must 
be taken that the label is inputted correctly in the cell. If a label is misspelled or the 
capitalization is wrong, two different labels will be created that mean the same thing. To 
help this problem, the label tree popup menu can be accessed in any cell by holding 
down OPTION and clicking in a cell. The label tree popup menu will appear and the labels 
can be added or removed. Using the label tree is the best way to make sure that labels 
are consistently inputted in the sorter window.
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SORTER WINDOW*

Sorting Rows
Columns in the sorter window can be automatically sorted in 
5 different ways. To access the sorting options, right click on the 
column header name cells.

1.  Sort Ascending sorts the rows in alphabetical order from A-Z according to the data found in 
the column. Numbers will be sorted from lowest to the greatest number.

2.  Sort Descending sorts the rows in reverse alphabetical order from Z-A according to the data 
found in the column. Numbers will be sorted from the greatest to the lowest number.

3.  Sort Frequency Ascending sorts the least frequent found text or number in the column and 
groups those at the top, the next least frequent found text or number is placed 
below this grouping. This pattern is followed through out the column of data.

4.  Sort Frequency Descending sorts the most frequent found text or number in 
the column and groups those at the top, the next most frequent found text or 
number is placed below this grouping. This pattern is followed 
through out the column of data.

5.  Sort All Rows by Movie Time sorts the rows according to the 
instance start time. This sorting option only works when clicking 
on the time reference column header.

Synchronizing Changes Back to the 
Timeline
After making changes to the duration of i n s t a n c e s , 
the labels, and instance notes in the rows of a sorter window. The changes can be synchronized 
back to the original timeline. Select the specific rows in the sorter to be synchronized, then press 
the synchronize button in the sorter tool bar. To synchronize all the rows, press COMMAND+A to 

select all the rows, then press the synchronize button. When synchronizing data back 
into timelines, the original timelines must be open.

NOTE: The purpose of requiring the timelines to be open is to insure that accidental synchronization does not 
occur. Changes made through synchronization cannot be undone once the timeline is saved. By default, the 
auto save timeline data preference is turned on.
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OVERLAY TEXT DISPLAY OPTIONS IN THE SORTER*
Each column of data in the sorter window can be turned off for overlay text display. When the 
column type icon has cross through it, the data will not be shown as overlay text.

This is used to limit what is presented in the movie and attention can be brought to specific 
data. The examples below show how turning off columns displays less data.

No columns turned off.

Row name column turned off.

Row name and Field Zone columns turned off.

Row name, Field Zone and Phase Play Start columns turned off.
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SAVING INSTANCE MOVIES
Any instance movie can be saved as a file for presentation, archive, or distribution purposes. 
So, after editing a movie, you can save your work.

1.  Click on the movie that you want to save so that it is the front most window. When saving, 
the front most window will be selected by the software as the window to save.

2.  Choose Save from the File menu in the main menu bar. Alternatively, you can press 
COMMAND+S or click on the save button in the main tool bar.

3.  Select the target save location and name the file.
4.  Set the required movie format from the bottom of the save window.

Studiocode stand-alone or MoviePlayer stand 
alone movie formats create files that contain all 
the necessary data to view the movie independent 
of the original movie file. Since stand alone movies 
contain all the necessary data to be played on its 
own, they tend to be large files. Stand alone files 
are required when you wish to share the movie 
with other people on their computers.
Studiocode or MoviePlayer reference to original 

movie formats create reference files that point to original movies. Reference movies are very 
small in size and save very fast as they do not contain any raw video data and thus do not 
duplicate video data. However, the file must have access to it’s original raw movies from which 
it was created. If you delete the original movie, a reference movie will not play. Use reference 
movies to quickly assemble an edit, then save it as a stand alone when you are done.
5.  Click the Save button.
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CONVERTING MOVIES
Any movie can be converted to another format using the convert movies features in this 
software. If Studiocode can view the file, it can be converted in some way to another format 
using this system.
The standard format for captured movies is DV. The DV format creates very large files, 
approximately 13.8GB of hard disc storage per hour of video. These files will fill up an internal 
hard disk very quickly. To save space, we recommend converting the files into an alternate 
format. Follow these instructions for a simple and fast method of converting any movie to a 
MPEG-4 format that is suitable for coding, editing, analysis, and presentation.
NOTE: Converting is commonly referred to as compressing since the purpose in most cases is to reduce 
(compress) the size of the file. Converting the movie creates a stand alone movie.
1.  Open an instance movie from a timeline that has a DV video linked to it. Set the video 

window size to half of its natural size. So, if your video is 720x480, set the movie size to 
360x240.

2. Choose Convert movie from the File 
> Export menu in the main menu bar. 
This opens the Save exported file as... 
window where you can set-up all the 
options for the conversion.

3. Choose Movie to Quicktime Movie 
from the Export drop down menu in 
the window. Then, press the Options 
button to configure the specific movie 
conversion settings. The Movie Settings 
window will open and the Video, Audio, 
and Internet settings can be changed.

4. In the Video area of the Movie Settings 
window, click on the Settings button. 
The Standard Video Compressor 
Settings window will open. In this 
window, configure the following: 
Frame Rate = Current 
Key Frames = All 
Compressor Quality = Medium 
Data Rate = Automatic

NOTE: Frame rate will be the same as the original. 
Every frame will be a key frame which converts a 
file that can be easily edited. Compressor quality 
at medium and the data rate at automatic will 
produce an acceptable movie where the algorithm 
will determine how to best convert the movie from 
various frame samples from the entire movie.
5. Click OK to save the settings.
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CONVERTING MOVIES...
 Next, configure the Audio settings.

6. In the Audio area of the Movie Settings window, 
click on the Settings button. This will open the 
Sound Settings window.

7. Set the Format to AAC, the Channels to Stereo (L R), 
the Rate to 48,000khz, Render Settings to Normal, 
and Target Bit Rate to 128kbps.

NOTE: These audio settings will create a CD quality audio track 
in the converted movie. If audio is not important, uncheck 
this option in the Movie Settings window and no audio will be 
exported. This will make the resulting file smaller, but when  
compared to video tracks, audio tracks are extremely small 
in size. So, in the long run, not choosing to use audio saves 
negligible hard disk space.

8. The last area in the Movie Settings window are 
the internet streaming options. If you are going to 
use the movie to stream from a file server on the 
internet, then you should select the appropriate 
settings as defined by the host of the server. 
For this example, uncheck Prepare for Internet 
Streaming options. For general use these settings 
should be turned off.

9. With the Video and Audio check boxes checked 
and the Prepare for Internet Streaming unchecked 
click the OK button in the Movie Settings window.

10.  In the Save exported file as window, type in a 
name and target location to export the file.

11.  Click OK to start the conversion process.

After the conversion is complete, these settings will 
be saved as the default settings. So, in most cases, 
they do not need to be set up again.
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CONVERTING MOVIES...
This movie conversion example is very basic and does not fully explore all the options that are 
available. This is a very complex topic and for the purposes of this manual, we will not offer an 
explanation for every compressor and its various options.

Using the settings described, you will likely find varying results over time. Some movies will 
be smaller in file size even though they are similar in length. Other times you will see quality 
differences in two similar movies. Because each movie is different in shot, composition and 
length, you will have varying results when translated by the compressor’s algorithm automatic 
settings. But using automatic settings is a good way to start understanding how to convert 
movies.

Here are a few tips to experiment and find what will work for you best for your particular 
purpose.
1.  Use a short instance to experiment with different settings. Waiting for long conversions is 

tedious and you will not always get the desired results.
2.  Set the frame size of the movie first. In most situations, 360x240 NTSC or 360x288 PAL 

is the right frame size to use. Studiocode will use the instance movies window size for the 
conversion size. There is a great difference in time to convert a movie that is twice that 
frame size.

3.  If file size is most important, try setting manual data rates. This will guarantee the file size 
and forces the conversion to use the same amount of data per frame. Start with 6400 kbps. 
Automatic settings will find the best data rate which can vary greatly from movie to movie.

4.  Try using different compressors. Use H.264 or Sorenson Video to convert a small clip and 
compare the results. Some compressors are better for different types of video. MPEG-4, 
H.264 and Sorenson are popular compressors, so sharing these formats will be compatible 
with any system running Quicktime 7.0 or greater.

5.  Adjusting the key frame intervals can make a big difference when video quality and size 
are concerned. Try setting the keyframes to 25 instead of all or 1 frame. Key frame settings 
greater than one every frame creates movies that will not be suitable for coding, editing, 
and slow motion analysis. Spreading out the key frame intervals, is recommended when the 
video will be distributed for playback only via internet or email.

6.  Video acquisition is probably the most important aspect to converting movies. If the video is 
poor quality to begin with, converting it will not make it better. Try to get the best copy of the 
video possible or get proper training on how to use your camera. Fast panning or zooming 
can cause conversion results to look very pixelated. To achieve the best results, avoid quick 
camera motions.

Drag and Drop Reference Movies
A quick and easy way to create reference movies for batch converting is to drag from the 
video in the movie window and drop onto the desktop. This will create a movie clipping on 
the desktop. As you drag and drop, rename the movies, so you don’t forget what video is in 
each one. Remember to select the segment of the movie in the instance movie timeline for 
which you want to create a movie clipping.
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EXPORTING MOVIES
DV Video Export
If a movie is in the DV format, then you can export using the DV export feature in the main tool 
bar. This will export the selected movie to a camera or an analog/digital convertor. If the movie 
is in a different format like MPEG-4, it will not export to the external devices. 

1.  Create the instance movie you wish to export.
2.  Select the instance movie, so it is the active window.
3.  Set your device to accept digital input.
4.  Click on the Export to... button    in the main tool bar. If the movie is exporting properly, 

the arrow in the icon will change from yellow to red. The video will appear in the 
camera or the device connected to the convertor.

5.  Play your instance movie. If you are exporting to a tape recorder or DVD burner, queue 
the movie to the beginning on the computer, press record on the recorder or burner, then 
hit play on the computer. For presentation, you can use all the fast forward, fast rewind, 
frame by frame, and slow motion features. If you switch instance movies, press the Export 
to... button again to begin exporting.

Video Out Export
When movies are not DV format, the only way to export full screen video to a recorder, burner, 
or projector/tv monitor is to use the video out port of the Apple computer. Plug in the external 
device using the DVI, Mini-DVI, or Video Out port on the computer. You may need to use a 
convertor cable to match the input of the external devices. With the hardware connected, follow 
these steps to enable the video to be exported.
1.  Open the Display preferences in the System Preferences of the computer. Click on the blue 

apple in the upper left corner of the screen, choose System Preferences from the menu.
2. Click on the Displays icon in System Preferences.
3.  In the Display preferences, click on the detect display button. This will export the desktop to 

the external device. The image will appear on the external device.
4.  There are two ways to export using the display settings. The first is mirroring the desktop, so 

that what is on the main screen of the computer is presented. There is a check box in the 
display preferences that will turn mirroring off or on. The second is extended mode where 
a secondary monitor is available to use as another screen for video export. The secondary 
display position can be moved in relation to the primary screen in the display preferences.

5.  If mirroring is enabled, the exact image on the computer will be displayed on the secondary 
monitor. This is a common way to set this up as users tend to lose the mouse on the 
secondary monitor and find it difficult to manage two monitors especially when they are not 
side by side. If extending the desktop to a secondary monitor is used, an instance movie 
when presented in full screen will be exported in full screen to that monitor.
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TIMELINE SHARING*

During capture, Studiocode creates a second timeline file, so coded instances 
can be viewed by other computers over a network. This file can be found 
inside the movie package and can be opened by any Studiocode application. 
Studiocode creates this second file to guarantee that your active coding 
timeline is not corrupted or changed.

During capture, you will need to update this file with the most recent coded information. To 
update, click on the update button in the capture window. This writes out the .TLshare file, so 
that other users on the network will get the latest information.

The update button will need to be pressed continuously through out the event in order 
to update the information in this file, it is not a dynamic process. The update procedure 
should occur during off action periods of the event. This procedure begins a new movie 

file which will result in dropped frames in the overall movie resulting in non-realtime movie file. 
The reviewing station will automatically update the timeline after approximately 5 seconds of 
the update button being pressed.

If third party data is going to be imported that relies on a continuous synchronous capture, do 
not use the captured movie that was involved in the updating timeline share process. It will be 
fragmented and will not match up the imported data. Consider setting up a second capture 
that is never paused or updated during the event for use with this type of data import.

Before diving off into timeline sharing we strongly recommend consulting the IT department or 
Sportstec. The networking side of things can be quite tricky as every network is setup a little 
differently and might have some quirks that could present some real problems. 

This feature shares the video file over the network. Playing video over a network is very intense 
because of the large amount of data involved in the movie files. A robust network is extremely 
important. We recommend using gigabit ethernet switch when connecting the computers for 
this reason.

For purposes of this manual, a simple network between two computers running Mac OS X 10.5 
will be outlined. Again, contact the IT department or Studiocode if more explanation is required 
or help is needed.
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TIMELINE SHARING*

Setting Up The Network
Each computer will be assigned a static IP address in the networking panel of the system 
preferences.

1.  Navigate to the Network preferences panel:
A.  Click on the apple in the upper left hand corner of the screen.
B.  Choose System Preferences... from the menu.
C.  Click on the Network icon in the System Preferences panel.
D.  Click on Ethernet in the list of the network preferences panel.

2.  Configure the capture/coding computer ethernet port to a static ip address.
  A. Configure = Manually
  B. IP Address = 10.0.1.1
  C. Subnet Mask = 255.255.255.0
  D. Press the Apply button.

3.  Configure the viewing computer ethernet port to a static ip address.
  A. Configure = Manually
  B. IP Address = 10.0.1.2
  C. Subnet Mask = 255.255.255.0
  D. Press the Apply button.

Network Locations
A handy Mac OS feature is network locations. Locations can be switched quickly to 
configure the system from one network environment to another.
1.  Open network preferences panel in System Preferences.
2.  Click on the Location menu in the top of the panel and choose Edit Locations...
3.  Add a new location and give it a name suitable for the network environment.
The newly created location will have all the settings that are currently set in network 
preferences panel. If any changes are made, the changes will be saved for this location.
To quickly switch locations, click on the apple in the upper left corner, choose Location and 
select the proper network environment.
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TIMELINE SHARING

Setting Up The Share
Now that the networking setup, file sharing must be turned on on the capture/coding computer 
in order to gain access to the timeline share file.

1.  Navigate to the Sharing preference panel:
A.  Click on the apple in the upper left hand corner of the screen.
B.  Choose System Preferences... from the menu.
C.  Click on the Sharing icon in the System Preferences panel.

2.  Turn on File Sharing by ticking the box in the list.

3.  Add a folder to share where the file will be captured by clicking on the plus button at the 
bottom of the Shared Folders list. To make the process most convenient, 
choose the ~/Desktop as the share point. This is an easy location to 
remember and manage.
There are options to setup user privileges and other permissions. To 
keep it simple take note of the user that is listed by default and do not 
add any others. The current user that is logged should be listed with 
Read & Write privileges. The user name and password for this user 
must be known and will be used to log in from the viewing computer.

Connecting To The Shared Folder
With the network settings and sharing in place, connect the two computers via an ethernet 
cable.
To check connectivity, open the Network preferences panel and look for a green light next to 

ethernet.
On the viewing computer connect to the capture/coding computer 

shared folder.
1.  Open Finder and press COMMAND+K.
2.  In the Connect to Server window type in the IP address of the capture/coding computer, 

10.0.1.1.
3.  The login screen will pop up, login using the user name and password for that of the capture/

coding computer.

4.  Choose the ~/Desktop folder in the list and click OK. This will mount the folder and it can be 
accessed in Finder to open the timeline share.
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TIMELINE SHARING

Opening The Timeline Share
The timeline share can be opened by double clicking on the movie package that is being 
captured on the capture/coding computer. Alternatively, the .TLshare file is found inside the 
package. To access the package contents, right click on the package and choose Show package 
contents from the contextual menu. This will open the package and the timeline share file can 
be double clicked or dragged onto the Studiocode icon in the Dock.

The timeline share file does not show up in the package until the first time the update 
button is pressed in the capture window on the capture/coding computer. It is common 
practice to press the update button shortly after starting capture, so that the timeline 

share file is available to the viewing computer as soon as possible.

Once the timeline share file is open on the viewing computer, it will update automatically after 
every time the capture update button is pressed on the capture/coding computer. The update 
on the viewing computer occurs approximately 5 seconds after the update button is pressed 
on the capturing computer. The time it takes to update depends on network traffic and other 
processes that may be running on any of the systems.

The timeline share feature requires a lot of resources to run smoothly. We recommend any 
computers used in conjunction with this feature be dedicated to this alone. Other applications 
should not be running.

Update Code Button
A code button in the code window can be created to update the capture when it is pressed 
down.
1.  Create a new code button in the code window.
2.  Name the code button <capture_update>.
3.  Set the code button with a lag time. The lag time amount depends on how long the 

update process should happen after the button is clicked.
A good approach to using the <capture_update> button is to have it activated by another 
code button with lag time. Set the lag time for the <capture_update> button 1 second 
longer that the code button that triggers it. When the code button ends its lag, the <capture_
update> button will trigger the update process 1 second later.
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REMOTE COMMUNICATIONS

A flexible network feature, Studiocode remote communications are designed to provide one or 
more computers the power to control and share information on multiple computers during the 
capture and coding process. It can start, pause, resume, and end capture on client computers 
over a local area network or even over the Internet. Along with capture control commands, 
it can mirror code window button pushes on one computer to another computer, so coded 
information can be shared in near real time.

Like the timeline share feature, remote communications requires networking configuration. 
While the communications feature is not nearly as intense on the network, we recommend 
running this feature over a gigabit ethernet network. This will insure that the best possible 
network environment is in place. Wireless networks can be employed, but suffer from drop 
out and range problems especially in highly populated areas where there are a lot of mobile 
communication networks and active devices. For purposes of explaining this feature, we will 
assume the same ethernet network configuration is in place and connected as described in 
the setting up the network aspect of the timeline share section of this manual.

Server And Client
The key to setting up this feature is understanding the roles of the server and client as we 
define them. A server is computer that sends commands to a client. The client is a computer 
that executes the commands sent by a server. Any computer can be both be a server and a 
client to other computers. This is often the case when mirroring code button pushes between 
two capture/coding computers.

Open the communications window by choosing File > Communication window.
The communication window is where clients can be added, suspended, removed and edited. 
Errors and logs can be accessed for trouble shooting or basic monitoring. Capture can be 
started, paused, resumed, and ended. The preference panel can be opened here too.

All available and connected Clients and Servers are shown in this window. The number of 
connected Clients and Servers are shown in the list on the left edge of this window.

NOTE: If remote communications are required to be sent over the Internet, IT consultation will be a must. This 
will require a high level of network experience and is a very involved setup. Please contact Studiocode to get 
more information on setting up remote communications over the Internet.
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REMOTE COMMUNICATION PREFERENCES 

Network Preferences
Open the remote communications preferences by clicking on the Preferences button 
in the Communications window or by choosing Studiocode > Preferences then click on 
the Network icon in the toolbar.

Name/Description

Set the name of the computer. This is the name that will appear in the Communications 
window. Use a name that best describes how the computer will be used. This will make it easier 
to identify computers in the list.

Password

Set the password and verification field for the computer. It is common practice to set all 
computers to the same password, so the auto connection feature can be used.
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REMOTE COMMUNICATION PREFERENCES 

Default Password for Auto Connection To Clients

Tick the box next to Use same password as default for auto connection to clients. This will try 
to connect with clients using the same password that is set above for the computer. A very 
convenient option to use when there are multiple clients to connect.

Allow Servers to Initiate Capturing

Tick this box to allow connected servers to start capture on the computer.

Do Not Show Errors As They Occur

Tick this box to stop the error log from popping up during remote communications. Keep this 
option ticked unless trouble shooting is required.

Capturing Does Not Capture Locally

Tick this box to stop the capture window from opening and starting capture when the capture 
button is pressed in the Communications window. This is commonly used when one computer 
is used for capture control only.

Port Settings

Port settings can be changed here. Studiocode uses 9093 which is a port left undefined by 
networking standards. When setting up for Internet remote communications, this may be 
changed to suit firewall rules. Be careful when changing this setting even on a local area 
network. Changing this could cause serious problems for a network where other services may 
be running over the same ports. Consult the IT department before changing this number.

Do Not Connect With Clients
Tick this box when the computer will be acting only as a client. The computer will not act as a 

server and send any commands to any clients. Commonly used when computer is acting as a 
client only.
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REMOTE COMMUNICATION PREFERENCES 

Stop Servers Connecting To This Computer

Tick the box to stop all servers from connecting to the computer. The computer cannot be a 
client when this ticked. Commonly used when the computer is acting as a server only.

Disable Automatic Connection To Clients

Tick this box to stop auto connecting to clients. This stops any attempt to find and connect with 
clients using Bonjour technology on the network. When this option is ticked, all clients must 
be added manually.

Stop/Disable All Communication!

Tick this box to stop all remote communications. We highly recommend that when remote 
communications are not being used that this box is ticked. Accidentally starting capture or 
code button pushing could be very problematic for other computers on the network.

CONNECTING TO CLIENTS FOR REMOTE COMMUNICATION
Clients can be added and connected in two ways. Automatically or Manually.

Click on the Clients button in the list on the left of the Communications window. Clients with 
remote communications enabled and servers with automatic connection to clients enabled 
will appear automatically in the main list of the communications window. If the default 
password for auto connect option is set, it will connect automatically too. The Bonjour icon 
will appear if connected automatically. If this is not set, then double click on the 
computer name and set the password in the window. Tick the Initiate recording on client 
computer if capture needs to be started on the client. A red button will appear next to the 
computer name when initiate capture is configured. When the client is connected, the 
status column will report connected other wise it will report password required or unable 
to connect to IP or Port.

1
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CONNECTING TO CLIENTS FOR REMOTE COMMUNICATION 

CAPTURING USING THE COMMUNICATION WINDOW*

To initiate capture in the communication window, press the red capture button in the 
toolbar. All connected clients that allow capture to be initiated will intitiate capture 
using the Quickstart capture feature. The file will be captured to the last location of 

capture on the client or the set Quickstart capture folder on the client. To set the Quickstart 
capture folder choose Capture > Quickstart set folder from the main menu bar along the top 
of the screen.

Pause and resume can be controlled by clicking on the Pause button in toollbar. If 
capturing is done locally, the local capture window can pause, resume and end.

Manually adding clients is used when no clients are readily available on the local area 
network or the client is being to connected to over the Internet via a public IP address 
or VLAN. This allows for all client configuration to take place before connecting to any 
network.
Click on the Clients button in the list on the left of the Communications window.

Add the clients manually by clicking on the Add button in the window.
Add the IP address or URL for the 
client, set the password, then press 
the Test button to check whether the 
client is ready to communicate. A 
timeout duration can be set to better 
synchronize communication. A longer 
timeout duration may need to be set if 
connecting over the Internet or there 
is heavy traffic over a slow network. 
When the password is set and the test checks out OK, press OK. If the test does not report 
back a positive result, the client can still be added. The client will be added in the list of 
clients. When a client is added in this fashion, the computer name will not appear in the 
list. Remember to set the initiate capture option if required.

2
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REMOTE COMMUNICATION CODING 

The most powerful and simple feature of remote communications is the ability to send 
button push commands from a server’s code window to a client’s code window. This means 
that multiple people can be coding on different computers, all feeding information to each 
other’s timeline or into a single timeline over a network. Using the Internet, capture and coding 
processes can literally be done across the globe.

The button push commands are sent from server computers to client computers 
automatically when code mode is activated in a code window. There are no configuration 
settings in the preferences for this feature of remote communications. The only things 

that are required are the connection to a client and the identical code windows on each 
computer.

There are a few items to note.
1.  Use identical code windows on each server and client. Remote button pushing is when a 

server code window sends the push command to the matching client code window. The 
client computer locates the button to be pushed down and pushes it down. If the same code 
window is not open on the client computer, no buttons will be pushed down, so no instances 
will be created in the timeline. 

2.  Multiple windows can be open at one time. It is a good practice to break down a single large 
code window into multiple smaller ones. This can make the coding process focused and 
accurate for the people coding. 

3.  Do not set the same hotkeys for multiple windows. When multiple code windows are open, 
the hotkeys may push down the wrong buttons if the same ones are set in the buttons of 
the windows.

4.  Capturing does have to occur locally on a server computer. Connect to a capturing client with 
the same code window open, open the same code window on the server and  activate code 
mode. The button pushes will start on the client even though the server is not capturing.

Imagine 20 or more people could be viewing the same event, coding on separate computers in 
different geographical location while all the data is being pushed into one capturing client. The 
possibilities for this feature are endless...
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OVERLAY TWO MOVIES 
Using the overlay feature you can take two 
instances and put them on top of each other 
to analyse the differences in the movies.

1.  Create two separate instance movies.
2.  Choose Overlay instance movies 

from the Windows menu in the main 
menu bar or press the shortcut 
OPTION+COMMAND+Y.

Align Two Overlaid Movies
1.  Create the overlaid movies as above.
2.  Press the SHIFT+OPTION keys, click in the movie frame and drag the top movie to align the 

area of interest with that of the second (lower) movie.
3.  When you play the movie the top and lower movies will stay in this aligned position.

CHANGE TRANSPARENCY LEVEL OF MOVIE WINDOWS

Choose Reduce transparency or Increase transparency from the Windows menu in the main 
menu bar. Use the shortcut keys CONTROL+OPTION+9 or CONTROL+OPTION+0, by pressing 
these repeatedly you can vary levels.

FLIP AN INSTANCE MOVIE

1. Create an instance movie.
2.  Choose Flip movie horizontally from the 

Windows menu in the main menu bar. The 
movie frame will be flipped horizontally.
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STACKING INSTANCE MOVIES
Two or more instance movies can be stacked in various configurations in one movie window. 
The only limiting factors to how many movies can be stacked are the computer’s screen 
size and speed. Each angle in the stack movie can be moved around the stack. The stack 
configuration can be changed; 1x2, 2x2, 4x1, etc. Any angle in the stack can be zoomed and 
the other movies in the stack are hidden from view.
1.  Open a timeline with some coded instances. Find three similar instances to view and make 

3 separate instance movies from each one.
2.  Set the playhead on each movie to a point at which all three movies will be in sync. This 

might be one second prior to a particular event.
3.  With all the sync points set in each instance movie, press COMMAND+Y or choose Stack 

instance movies from the Windows menu in the main menu bar.
4.  A stacked movie will open up with all three instances in a 3x1 configuration.
5.  To change the stack movie configuration, press CONTROL+COMMAND and click in the stack 

movie window. Select 1x3 or 3x1 from the pop up menu.
6.  To move an angle location in the configuration, press down COMMAND and click and drag 

the angle to another location in the window.
7.  To zoom an individual angle, press OPTION+COMMAND and double click on the angle in the 

movie window. Use the same procedure to zoom out to viewing all angles at once or press 
the stack movie button . The keystroke and mouse clicks work in full screen also.

To make viewing angles in the stack easier and avoiding constant rewinding of the movies, 

there are some playback features built in. 
For an instance movie with chapter markers.
1.  If the movie is playing and it is zoomed, the movie jumps back to the previous chapter 

marker.
2.  If the movie is stopped and it is zoomed, the movie only changes views and does not jump.
For an instance movie without chapter markers or a timeline movie.
1.  If the movie is playing and it is zoomed, the movie jumps back 10 seconds by default. This 

time can be adjusted in the movies preference panel.
2.  If the movie is stopped and it is zoomed, the movie only changes views and does not jump.

NOTE: If you wish to use this feature, we recommend using the most powerful computer that is available. When 
stacking 4 or more DV movies together, plan on using a desktop computer not a portable. Playing multiple 
movies simultaneously is very cpu and hard disk use intensive.
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STACKING TIMELINE MOVIES

Multiple timelines can be stacked to create a single timeline and linked stack movie. After 
capturing and coding multiple synchronous camera angles of an event, each timeline can be 
merged into a single stacked timeline.

Stacking timelines merges all the coded instances in the timelines that are being stacked. If 
the same rows exist in each timeline, the instances and rows will be merged into one in the 
new timeline.

Stacking timelines requires synchronous video. So, it is important that all captures are 
continuous through the whole event. Pausing and resuming capture will cause the movies to 
be out of sync. We recommend starting capture 1-2 minutes prior to the start of the event. It is 
also a good idea to capture audio.

Audio is a great way to find the synchronization point of a movie. If all cameras are not pointed 
at the same thing when the event starts, audio can provide solid clues to find a worthy sync 
point.

Stacking timelines is basically the same process as stacking instance movies.
1.  Close all windows except for the timelines and movie windows that are going to be stacked.
2.  Find the sync point in each timeline and position the playhead on each timeline to that point. 

It is a good idea to move the playhead back a couple of seconds by pressing OPTION+LEFT 
ARROW on each timeline after setting the sync point. This will give a little extra movie time 
prior to the first event that might need to be coded.

3.  Choose File > Stack timeline movies.
4.  Name the file and save it. Remember to check what type of package is being created when 

you save. Standalone, reference and compressed are all options. We recommend creating 
a reference package first, so the results can be checked quickly. Do not delete the original 
movies until you have saved it as a stand alone package.

When saving standalone packages, check the file size, stacked timelines can create some very 
large files.
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COMBINING TIMELINES
Two or more timelines can be combined back to back, so analysis over multiple movies can 
be performed very quickly. The combine timeline process creates a reference package. A 
reference package takes up very little space, but remember do not delete the original movies 
until the project is finished or saved as a stand alone package.
1.  Choose Combine timeline 

movies from the File menu 
in the main menu bar.

2.  Locate the timelines you 
want to combine.

3.  Select and add each one 
in the order you want them 
to appear into the new 
timeline.

4.  With all the timelines 
added, press the Combine 
button.

5.  Name the file and save.

DATABASING INSTANCES
Databasing provides an easy method to group specific coded instances into one timeline. 
Studiocode creates stand alone databases that hold all the coded information and video data 
for each instance that is exported to it. Databases are a great way to keep only the information 
that you code. A neat way to use databases is to create one for each student. As a research 
project progresses, instances from different movies can be exported into their personal 
database. By the end of the project, each student has a database of selected instances already 
made and ready for review.
1.  Create a new empty database by choosing Database from the File > New menu in the main 

menu bar.
2.  Name the database and save it.
3.  Open a timeline with the instances you want to export. Select all the instances to 

be exported, then press the database button in the timeline tool bar.
4.  Target the database to export to, and hit the Export to button.
5.  Open a second timeline, select instances, and export them into the same database. These 

instances will append to the database. Continue this process until complete.
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CODE MATRIX
The code matrix is a two dimensional grid representation of code rows and text labels in a 
timeline. The rows in a matrix are generated from the rows in a timeline. The columns are 
the text labels that are coded in the instances of the rows. The cells of the matrix display the 
instances that have the text label coded in them. The intersection cells count the instances 
that have the text labels coded in them. It does not count the amount of text labels in the 
instance. The matrix is an instance counter, not a text label counter.

Using a Code Matrix
1.  Click on the Matrix button in a timeline or 

code window.
2.  Double click on the row name to create a 

movie for all instances in the row.
3.  Double click on the column name to create a 

movie for all instances with the text label.
4.  Double click on a cell to make a movie of the 

intersection of instance and label.

 The cumulative totals of columns and rows can also 
be highlighted and viewed. These totals represent 
the total instances in the timeline from which the 
matrix was generated. Double click on these totals 
to make a movie.
NOTE: When a row name, text label, cell or total is clicked 
on, the instances are selected in the timeline. The matrix 
can be used to select instances to paste into a movie 
organizer or sorter window.

To Print A Code Matrix 
Click on the print button in the matrix tool bar. Add a title to the matrix by editing the text box 
to the right of the print button.

To Copy A Code Matrix As A Picture 
1.  Place the mouse cursor in blank area of the upper left corner of the matrix window then 

click and drag over the matrix grid. A bounding box will appear on the area that was 
dragged over.

2.  Press COMMAND+C to copy the matrix to the clipboard. A snapshot of the matrix can be 
pasted into a Word document or any other text editor that accepts images.

To Copy A Code Matrix As A Table
1. In the Matrix Window, place the cursor on the matrix.
2.  Hold down CTRL and click in the matrix grid. Select “Copy table as text” from the pop up 

menu. This will copy the matrix as a table to the clipboard.
3. Paste the table into a Word or Excel document.
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CODE MATRIX

Create A New Code Row In The Timeline 
1.  Select column in the matrix by clicking on the text label column header.
2.  A new row can be created from the matrix by pressing CTRL while clicking on the selected 

text label column header. Select Make Timeline row from selected cells. This will create a 
new row in the timeline with a row name of the text label.

DYNAMIC CODE MATRIX
The Code Matrix can be set to display data within specified time ranges.
1.  Drag the markers in the matrix window to the required time range. Set the left marker to 

the starting time, then drag the right marker to set the end time. 
2.  The Matrix will now display only the data found within the specified time range.

Dynamic Code Matrix Hot Tips:
Use the dynamic code matrix to compare two time ranges in a timeline. For example the 
first 10 minutes versus the last 10 minutes of a simulation or scenario.
1.  Set the dynamic matrix ranges to the first 10 minutes of the event.
2.  The data in the dynamic matrix can be copied and pasted into an Excel spreadsheet. 

Hold down the CTRL key and click on a matrix. Choose Copy Table as Text and paste 
the table into an Excel spreadsheet.

3.  Set the ranges for the last 10 minutes of the event and repeat the above procedure.
NOTE: To highlight the associated Instances within the timeline, hold down OPTION and click on the 
matrix. The Instances that fall in the time range in the matrix will now be selected in the timeline.
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CODE MATRIX ORGANIZER
Using the code matrix organizer, a matrix can be organized to display specific in depth 
analysis. Text labels can be put together using boolean operators: and, or not. After 
customizing a code matrix organizer, it can be saved and opened at another time to use on 
another timeline.
Open a code matrix organizer by choosing Analysis>Code matrix organizer from main menu 
bar.

Organizing Rows
Drag rows by clicking on the row number and dragging the row to the new location.

Turn On Or Off labels
Click the button in the on or off column  in the rows of labels. When a row indicates on, it 
will appear in the matrix. When a row indicates off, it will not appear in the matrix.
Pressing the DELETE key on the keyboard will turn the label off.
Turn off or on all labels by pressing CTRL while clicking on the on or off button. Select All on 
or All off from the popup menu.

Duplicate A Row
1.  Select the row you want to duplicate by clicking on the row number.
2. Click on the Duplicate button in the code matrix organizer tool bar.

Duplicating rows makes it possible to combine multiple text labels against a single text label 
in the matrix.

Delete A Row
1.  Select the row you want to delete by clicking on the row number.
2. Press DELETE on the keyboard.
Only duplicate rows can be deleted. Deleting a row does not delete the text labels from the 
matrix generated in the timeline. It only deletes the row from the code matrix organizer.

Reset The Code Matrix Organizer
Press the reset button in the code matrix organizer tool bar. This will reset all the text label 

rows to represent the original generated code matrix organizer from the timeline. All 
duplicate rows and text label combinations will be removed.
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CODE MATRIX ORGANIZER

Combining Text Labels
The most powerful feature related to the code matrix is the ability to combine text labels in the 
code matrix organizer. Text labels can be combined together in a row using boolean operators: 
AND, OR, NOT.
1. Click and drag a text label from one row to another by clicking on the text label box in the row 

and dropping it next to another text label in a row above or below.

2. The default operator is AND. To change this, click on AND, then select OR or NOT from the 
popup menu.

AND will count instances where all the labels are found in an instance.
OR will count instances where any of the labels are found in an instance.
NOT is an exclusion operator that will exclude the chosen text label. Instances that contain the 
text label set to NOT will not be counted in the matrix.

To remove a combined label in a row, select it by clicking on it and press DELETE on the key-
board.

Save The Code Matrix Organizer
Choose File>Save or press COMMAND+S to save the code matrix organizer. The code 
matrix organizer file can be opened and used against other timelines coded with the 
same text labels.

To Export A Code Matrix To Microsoft Excel
Click on the Excel button in the code matrix organizer tool bar to export a file that repre-
sents a table like the matrix. This will export the data from the front most timeline. Using 
this table in Excel, formulas, charts and graphs can be used to create in depth analysis 

reports.



84

Part 4    Studiocode - Analysis

STATISTICAL WINDOW
The statistical window is a spreadsheet style window with the ability to perform complex 
calculations based around instances in a timeline. Mathematical and logical expressions can 
be built into scripts in each cell. The scripts are built into each cell individually. Each cell can 
hold text, show data, change background color, or text color according to actions from the 
scripts.
The statistical window scripts can be executed manually by pressing the execute button in the 
window or executed automatically upon a change in the timeline or the click of a button in the 
code window.
The statistical window can drive output from a script to a button in the code window. Scripts 
can written to change button colors and push buttons up or down according to customized 
calculations.
The statistical window is extremely flexible, rows and columns can be moved, added, and 
deleted to present the output in hundreds of ways.

Create A Statistical Window
Choose File > New > Statistical window from the main menu bar.

Moving Around A Statistical Window
Moving from cell to cell can be done in two ways.

Holding down the CTRL key 
and pressing the arrow 
keys will move the cursor 
in the direction of the 
arrow key that is pressed.

Pressing the TAB key will 
move the cursor from one 
cell to the next cell on the 
right. Pressing SHIFT+TAB 
will move the cursor from 
one cell to the next cell on 
the left.

1 2
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STATISTICAL WINDOW...

Adding Columns Or Rows
Press the new column or row buttons in the toolbar. A new column will be 
created to the right of the column where the cursor is located. A new row will be 
created below the row where the cursor is located. If the cursor is not in a cell, 

then the new column will be created to the right of the last column or the new row will be 
added below the last row in the window.

Moving A Column
Click and drag on the column information header where the column number is located, move 
the column to the new location.

Moving A Row
Click and drag on the row number, move the row to the new location.

Deleting A Column
To delete a column, press CTRL and click on the column 
information header. Select Delete column from the popup menu.

Deleting A Row
To delete a row, press CTRL and click on the row number. Select Delete row from the popup 

menu.

Sorting Rows By Column
Rows can be sorted by column by pressing CTRL and clicking on the column header name 

cell. This is useful when sorting rows alphabetically or 
numerically. Sorting options are explained further in the 
Sorter window section of this manual.

Opening The Edit Script Window
To add a script to a cell, press CTRL and click on a cell. Choose Edit script from the popup 
menu. This will open the script editor window.

After a script is added to a cell, the upper left corner of the 
cell will have a green triangle in it.
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STATISTICAL WINDOW...

Adding A Script
The edit script window is a very basic text 
editor with copy and paste functionality.

The window consists of two parts: the title 
of the cell and the script for the cell.

The title of the cell can be set so it can be 
referenced in another cell’s script.

The script for the cell is set in the area 
below the title.

The scripting language and commands 
are quite difficult to master, but extremely 
powerful. Each command is documented in this manual with examples. Work through these 
examples and email support@sportstec.com for further help.

Copy and Paste Rows with Scripts
Hold down OPTION and click and drag on the row number. This will create a duplicate row 
with all the scripts included. This is quite a time saver when creating rows that will have the 
the same columns of data in them like player statistics.

Use Cell References
Use a cell as a data place holder for script referencing. Setup a column where the player 
names are inputted, then reference this column by its name or coordinates in a script. This 
makes changing data very easy because it can be changed in the cell, not the script.
In the script, create a variable that reads the reference cell’s data.
$playername = cell(“Player”,$row)
show count “Handball” where row = $player
This variable will look to the player column in the same row and use this data in the script. 
By typing A.McGrath into the Player column cell, the script finds how many Handballs there 
were in the A.McGrath timeline row.

Copy to Excel
Data being displayed in the cells of a statistical window can be copied into Excel or any other 
spreadsheet program. Hold down COMMAND and click in the cell, then press COMMAND+C 
to copy the data to the clipboard. COMMAND+V will paste the data in the other applicaiton. 
A group of cells can be selected by holding down COMMAND, click in top left cell, then click 
in the bottom right cell of the group of cells to be copied.
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STATISTICAL COMMANDS QUICK GLOSSARY

$COLUMN Returns the column the cell is in.

$ROW Returns the row the cell is in.

ABS Returns the absolute value of a number.

AND If values are numbers: returns 1 if both values are not zero, otherwise 
returns 0. If using text then it is assumed that you are referring to labels 
and the return result will be instances from the timeline that contain both 
labels. “AND” is commonly used inside other commands (see IF, COUNT...) 
and can be combined with “OR” and “NOT”

CEILING Returns a number which has the number rounded up to the specified 
number of digits from the decimal point. If you need to display a certain 
number of digits after the decimal point use the decimal command.

CELL Grabs the output from another cell in the window.

CELL_COLOR Changes the color of the cell.

COUNT Counts the number of labels in the timeline (including multiple ones in the 
same instance).

DECIMAL Returns a string which has the number to the specified number of digits 
from the decimal point. The number is always rounded down.

END Gives the latest end time of the labels or instances in the timeline in 
seconds. returns -1 if no instances.

END TIME Returns all instances that have the correct end time condition.

FLOOR Returns a number which has the number rounded down to the speci-
fied number of digits from the decimal point. This is similar to DECIMAL 
excepts that it returns a number and not a string. If you need to display a 
certain number of digits after the decimal point use DECIMAL.

IF Executes the statement based on a condition.

INSTANCES Returns all the instances in the timeline.

INSTANCE[x] Returns the ‘x’th instance in the timeline based on start times.

LABELS Returns all the labels in the timeline. If an instance has 3 labels it will 
return the instance 3 times.

LENGTH Gives the length of labels in the timeline (including multiple ones in the 
same instance) in seconds.

LIMIT Limits instances based on conditions.
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STATISTICAL COMMANDS QUICK GLOSSARY

NOT If value is number: returns 1 if value is 0, otherwise returns 0. 
If using text then it is assumed that you are referring to labels 
and the return result will be instances from the timeline that 
do not contain the label. “NOT” is commonly used inside other 
commands (see IF, COUNT...) and can be combined with “AND” 
and “OR”.

OR If values are numbers: returns 1 if either value is not zero, 
otherwise returns 0. If using text then it is assumed that you are 
referring to labels and the return result will be instances from 
the timeline that contain either label. “OR” is commonly used 
inside other commands (see IF, COUNT...) and can be combined 
with “AND” and “NOT”.

OVERLAP Returns instances from the given arguments that overlap for any 
part of the timeline. Opposite of UNIQUE.

PUSH BUTTON Pushes the button up/down in the code window. If this is a label 
button then you only need to use DOWN.

ROUND Returns a number which has the number rounded to the speci-
fied number of digits from the decimal point. It will round up 
or down depending on which is the closest digit. If you need to 
display a certain number of digits after the decimal point use 
DECIMAL.

ROW_COLOR Changes the color of the row.

SEND Changes the value of the button in the code window with that 
button name.

SEND BUTTON COLOR Changes the background color of the button in the code window 
with that button name.

SEND TEXT COLOR Changes the text color of the button in the code window with 
that button name.

SHOW Outputs the number or text to the cell.

START Gives the earliest start time of the labels or instances in the 
timeline in seconds. Returns -1 if no instances found.

START TIME Returns all instances meeting the correct start time condition

SUM Adds all the values in the cell group.

TIME Returns all instances meeting the instance length condition

UNIQUE Returns instances from the given arguments that do not overlap 
for any part of the timeline. Opposite of OVERLAP.

WHERE Selects certain instances based on conditions.
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DISPLAY COMMANDS
These commands change the display of the cell that the script is in.

CELL_COLOR changes the color of the cell. The color ranges are 0 to 100 percent of red, 
green, and blue. Different percentages of each color will result in different colors.
Format:
CELL_COLOR ( red , green , blue )
Arguments:
red: a number 0 to 100
green: a number 0 to 100
blue: a number 0 to 100
Example:

cell_color (100,0,0) turns the background color of the cell red.

cell_color (100,100,0) turns the background color of the cell yellow.

ROW_COLOR changes the color of the row. The color ranges are 0 to 100 percent of red, 
green, and blue. Different percentages of each color will result in different colors.
Format:
ROW_COLOR ( red , green , blue )
Arguments:
red: a number 0 to 100
green: a number 0 to 100
blue: a number 0 to 100
Example:

row_color (0,0,100) turns the row background color blue.

row_color (100,50,0) turns the row background color orange.

SHOW outputs the number or text to the cell.
Format:
SHOW value
Arguments:
value: numerical expression or quoted text
Example:

show “Hello” displays Hello in the cell when the scripts are executed.
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INFORMATION COMMANDS
Information commands return information about timelines and statistical windows.

CELL grabs the output from another cell in the window. This command is useful in calling on 
another cell’s output to be used in an expression or variable.
Format:
CELL reference
Arguments:
reference: (column number or column title , row number), quoted text representing a cell or 
the column title.
Example:

show cell (2,1) returns the output from the cell in column 2, row 1

show cell “my cell title” returns the output from the cell which has a title “my cell title”

show cell “my column title” returns the cell which has a column title of “my column title” on 
this cell’s row

show cell (“Column 1”,3) return the cell which has a column title of “Column 1” on row 3

show cell ($column-1,$row+2) returns the contents of the cell 1 row to the left and 2 rows 
down

show cell (“Column 2”,$row-2) returns the contents of the cell which has a column title of 
“Column 2” and 2 rows up from this cell

COUNT will count the number of labels in the timeline including multiple ones in the same 
instance.
Format:
COUNT labels
Arguments:
labels: quoted text specifying label you wish to count in the front timeline or instances(which 
can be grouped using OR, AND, NOT) optional WHERE conditions
conditions: ROW = quoted text or ROW != quoted text (which can be grouped using OR, AND, 
NOT)
Example:

count “score” returns a count of all the “score” labels in the front timeline.

count “score” and “fouls” where row = ”smith” returns the total number of “score” and 
“foul” labels in the row “smith”

count “score” where row != ”smith” returns the total number of “score” labels which are not 
in row “smith”

$a = not (“shot” or “foul”)
show count $a
This example uses a variable and shows the total number of labels in the front timeline which 
do not have “shot” or “foul” labels in them. Variables are handy to use in long expressions or 
scripts saving a lot of time in retyping or changing conditions.
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INFORMATION COMMANDS...

END will give the latest end time of the labels or instances in the timeline in seconds. It will 
return -1 if no instances are found.
Format:
END instances
Arguments:
instances: instances or quoted text specifying label you wish to get the latest end time
Example:

end “score” returns the end time of the latest instance which has the label “score” in sec-
onds

end “score” and “fouls” where row = ”smith” returns the latest end time of “score” and 
“foul” labels in the row “smith”

end instances returns the end time of the last instance. i.e. The latest overall end time

show end instance[-1] shows the end time of the last instance (based on start time). This 
might not be the latest overall end time

END TIME will return all instances that have the correct end time condition that meets the 
criteria in the argument.
Format:
instances WHERE END TIME operator value
Arguments:
instances: quoted text specifying label you wish to count in the front timeline or 
instances(which can be grouped using OR, AND, NOT)
operator: < <= > >= =
value: the end time you wish to test (in seconds)
Example:

count instances where end time > 20 will count the number of instances that have an end 
time after 20 seconds

count “a” or “b” where row = ”row1” and end time > 20 will count the instances that have 
“a” or “b” in them in row “row1” ending after the first 20 seconds

count instances where (start time <4 or end time >20) and time<4 will count all the in-
stances which are smaller than 4 seconds, and have a start time in the first 4 seconds or an 
end time after the last 20 seconds.

INSTANCES will return all the instances in the timeline.
Format:
INSTANCES
Example:

length instances returns the total length of the instances in the timeline.

count instances returns the total number of instances in the timeline.
Use in conjunction with WHERE to select particular rows.
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INFORMATION COMMANDS...

INSTANCE[x] will return the x’th instance in the timeline based on start times.
Format:
INSTANCE[index]
Arguments:
index: a number less than or greater than 0. if index is greater than 0 then it will count from 
the beginning. eg. 1 represents the first instance in the timeline, 2 the second instance etc. 
If index is less than 0 it will count from the end. eg. -1 represents the instance with the latest 
start time, -2 the second latest start time etc.
Example:

length instance[2] returns the length of the second instance in the timeline.

length instance[-3] returns the length of the third last instance in the timeline.
If you wish to have more control then the LIMIT command should be used

LABELS will return all the labels in the timeline. If an instance has 3 labels it will return the 
instance 3 times.
Format:
LABELS
Example:

count labels returns the total number of labels in the timeline.
Use in conjunction with WHERE to select particular rows

LENGTH will give the length of labels in the timeline (including multiple ones in the same 
instance) in seconds
Format:
LENGTH labels
Arguments:
labels: quoted text specifying label you wish to get the length of in the front timeline or 
instances(which can be grouped using OR, AND, NOT) optional WHERE conditions
conditions: ROW = quoted text or ROW != quoted text (which can be grouped using OR, AND, 
NOT)
Example:

length “score” returns the total length in seconds of all the “score” labels in the front time-
line

length “score” and “fouls” where row = ”smith” returns the total length of “score” and 
“foul” labels in the row “smith”

length “score” where row != ”smith” returns the total length of “score” labels which are not 
in row “smith”

length “score” where row != ”smith” or row != ”fred” returns the total length of score labels 
in the front timeline which are not in row “smith” or row “fred”

show length instance[1] shows the length in seconds of the first instance in the timeline
instances(which can be grouped using OR, AND, NOT)
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INFORMATION COMMANDS...

LIMIT will limit instances based on conditions that meet the criteria in the argument.
Format:
instances LIMIT offset,select
instances LIMIT select
Arguments:
instances: quoted text specifying label you wish to count in the front timeline or 
instances(which can be grouped using OR, AND, NOT)
offset: the offset to start counting. eg. 1 = will skip the first instance etc. If offset < 0 then will 
count from end. eg. -1=last instance. Can be left out if offset is 0.
select: how many instances to select. If select < 0 it will select up to the end value (-1=last, 
-2=2nd last etc...)
Example:

instances limit 2 will grab the first 2 instances

instances limit 4,2 will offset 4 instances and select the next 2. That makes it the 5th and 
6th instance.

instances limit 4,-1 will grab the 5th to the last instance.

instances limit -3,-2 will grab the 3rd and 2nd last instance.

length “a” or “b” where row = ”row 1” or row = ”row 2” limit 3,2 returns the total length of 
the 4th and 5th labels in the timeline with a or b in them and the row = ‘row 1’ or ‘row 2’

OVERLAP will return instances from the given arguments that overlap for any part of the 
timeline. (This is opposite of the unique command.)
Format:
OVERLAP ( instances , instances )
Arguments:
instances: labels or instances
Example:

overlap (“label 1”,“labels 2”) returns all instances which have label 1 in them and overlap 
with any instance containing label2 in them. It will also return all instances which have label 
2 in them and overlap with any instance containing label 1. It will also return instances with 
both labels in them but only once.

overlap (instances,instances) will return all the instances as every instance will overlap itself

overlap (instance[1], instance[2]) returns both the first and second instance in the timeline 
provided they overlap. Otherwise it will return nothing

show start overlap (“label 1” where row = ”row 1” ,”label 2” where row = ”row 2”) will 
show the start time of the first instance that overlaps where label 1 is in row 1 and label 2 is 
in row 2
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INFORMATION COMMANDS...

START will give the earliest start time of the labels or instances in the timeline in seconds. It 
will return -1 if no instances are found.
Format:
START instances
Arguments:
instances: instances or quoted text specifying label you wish to get the earliest start time
Example:

start “score” returns the start time of the earliest instance which has the label “score” in 
seconds

start “score” and “fouls” where row = ”smith” returns the earliest start time of “score” and 
“foul” labels in the row “smith”

start instances returns the start time of the first instance

show start instance[-1] shows the start time of the last instance (based on start time)

START TIME will return all instances that have the correct start time condition that meets 
the criteria in the argument.
Format:
instances WHERE START TIME operator value
Arguments:
instances: quoted text specifying label you wish to count in the front timeline or 
instances(which can be grouped using OR, AND, NOT)
operator: < <= > >= =
value: the start time you wish to test (in seconds)
Example:

count instances where start time < 20 will count the number of instances that have a start 
time in the first 20 seconds

count “a” or “b” where row = ”row1” and start time < 20 will count the instances that 
have “a” or “b” in them in row “row1” starting in the first 20 seconds

count instances where (start time <4 or end time >20) and time<4 will count all the in-
stances which are smaller than 4 seconds, and have a start time in the first 4 seconds or an 
end time after the last 20 seconds.
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INFORMATION COMMANDS...

TIME will return all instances that have the instance length condition that meets the criteria 
in the argument.
Format:
instances WHERE TIME operator value
Arguments:
instances: quoted text specifying label you wish to count in the front timeline or 
instances(which can be grouped using OR, AND, NOT)
operator: < <= > >= =
value: the instance length you wish to test (in seconds)
Example:

count instances where time < 20 will count the number of instances that are shorter than 
20 seconds in length

count “a” or “b” where row = ”row1” and time < 20 will count the instances that have “a” 
or “b” in them in row “row1” and are shorter than 20 seconds

count instances where (start time <4 or end time >20) and time<4 will count all the in-
stances which are smaller than 4 seconds, and have a start time in the first 4 seconds or an 
end time after the last 20 seconds.

UNIQUE will return instances from the given arguments that do not overlap for any part of the 
timeline. (Opposite of the overlap command.)
Format:
UNIQUE ( instances , instances )
Arguments:
instances: labels or instances
Example:

unique (“label 1”,“labels 2”) returns all instances which have label1 in them and do not 
overlap with any instance containing label2 in them. It will also return all instances which 
have label2 in them and do not overlap with any instance containing label1

unique (instances,instances) will do nothing as there will be no unique instance as it will 
overlap with itself

unique (instance[1],instance[2]) returns both the first and second instance in the timeline 
provided they do not overlap. Otherwise it will return nothing

show start unique (“label 1” where row = ”row 1” ,”label 2” where row = ”row 2”) will 
show the start time of the first instance that does not overlap where label 1 is in row 1 and 
label 2 is in row 2
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INFORMATION COMMANDS...

WHERE will select certain instances based on conditions that meet the arguments.
Format:
labels WHERE conditions
Arguments:
labels: quoted text specifying label you wish to count in the front timeline or instances(which 
can be grouped using OR, AND, NOT)
conditions: ROW = quoted text or ROW != quoted text (which can be grouped using OR, AND, 
NOT)
Example:

count “a” or “b” where row = ”row 1” or row = ”row 2” returns the total number of labels in 
the timeline with a or b in them and the row = ‘row 1’ or ‘row 2’

count instances where row != ”row 1” returns the total number of instances in the timeline 
not counting those in ‘row 1’.

LOGICAL COMMANDS
Logical commands are used to create boolean operations in an expression to help narrow 
down specific searches and arguments.

AND is used to combine arguments in order to specify a search more directly. If values are 
numbers: returns 1 if both values are not zero, otherwise returns 0. If using text then it is 
assumed that you are referring to labels and the return result will be instances from the 
timeline that contain both labels. “AND” is commonly used inside other commands (see IF, 
COUNT...) and can be combined with “OR” and “NOT”
Format:
labels AND labels
number AND number
Arguments:
labels: quoted text representing labels in the timeline
number: numerical expression
Example:

show count ”block” and “spike” shows the number of instances with labels “block” and 
“spike” in them

show count not (“a” or “b” and “c”) counts the number of instances that do not have “a” or 
have “b” and “c” as labels in them. AND will be calulated first before the OR as it has higher 
priority. Use brackets to force logic.
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LOGICAL COMMANDS...

IF executes the statement based on a condition
Format:
IF (condition, true statement, false statement)
IF (condition,true statement)
Arguments:
condition: if this numeric value is 0 it is considered false and will execute the false statement 
otherwise any nonzero result is considered true and will execute the true statement. You can 
use any relational operators <,<=,>,>=,=,!= on numbers or quoted text and logical operators 
AND, OR, NOT on numbers. When an empty string is compared to a number with = or !=, the 
string will be consdiered as 0.
statement: any normal command including another “IF”
Example:

if (5<6, show “true”, show “false”) shows true. You can change the result by changing the 
condition to 6<5

$a = cell(1,0)
if ($a < 0, show “cell is negative”, show “cell is positive”)
Using a variable, this example shows whether cell in column 1, row 0 is positive or negative 
number

$a = cell(1,0)
if ($a != 0, show 5/$a, show “N/A”)
Again using a variable to set the cell location, this example shows 5 divided by the contents 
of cell in column 1, row 0. If that cell is 0 or blank then show “N/A”

if (“tom” < “tot” and 4<5, show “true”, show “false”) shows true

if (“tom” < “tot” and 6<5, show “true”) will do nothing as the condition is false and there is 
no false statement
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LOGICAL COMMANDS...

NOT is used to exclude criteria in arguments in order to specify a search more directly. If 
value is number: returns 1 if value is 0, otherwise returns 0. If using text then it is assumed 
that you are referring to labels and the return result will be instances from the timeline that 
do not contain the label. “NOT” is commonly used inside other commands (see IF, COUNT...) 
and can be combined with “AND” and “OR”
Format:
NOT labels
NOT number
Arguments:
labels: quoted text representing instances labels in the timeline
number: numerical expression
Example:
$a = not “spike”
show count $a
This example shows the number of instances that do not have “spike” in them.

show count not (“a” or “b” and “c”) counts the number of instances that do not have “a” or 
have “b” and “c” as labels in them. AND will be calulated first before the OR as it has higher 
priority. Use brackets to force logic.

OR is used to combine criteria in arguments in order to specify a search more directly.
If values are numbers: returns 1 if either value is not zero, otherwise returns 0. If using text 
then it is assumed that you are referring to labels and the return result will be instances from 
the timeline that contain either label. “OR” is commonly used inside other commands (see IF, 
COUNT...) and can be combined with “AND” and “NOT”
Format:
labels OR labels
number OR number
Arguments:
labels: quoted text representing labels in the timeline
number: numerical expression
Example:
$a = ”block” or “spike”
show count $a
This example shows the number of instances with either “block” or “spike” in them

show count not (“a” or “b” and “c”) counts the number of instances that do not have “a” or 
have “b” and “c” as labels in them. AND will be calulated first before the OR as it has higher 
priority. Use brackets to force logic.
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NUMERIC COMMANDS
These commands perform numeric calculations. All standard mathematical functions +,-
,*,/,(),^ can be used. eg. show 7+8

ABS returns the absolute value of a number.
Format:
ABS (number)
Arguments:
number: numerical expression
Example:

show abs(-5*2) returns 10.

CEILING returns a number which has the number rounded up to the specified number of dig-
its from the decimal point. If you need to display a certain number of digits after the decimal 
point use the decimal command.
Format:
FLOOR (number ,number of digits)
Arguments:
number: numerical expression
number of digits: if positive the number of digits to show at the right of the decimal point. If 
negative, the number of digits to the left of the decimal point starting at tens. If 0 no decimal 
placing will be left
Example:

show ceiling (34.23001, 2) returns 34.24

show ceiling (3423.456, -2) shows 3500

show decimal (ceiling(0.1,0) ,2) shows 1.00

DECIMAL returns a string which has the number to the specified number of digits from the 
decimal point. The number is always rounded down.
Format:
DECIMAL (number ,number of digits)
Arguments:
number: numerical expression
number of digits: if positive the number of digits to show at the right of the decimal point. If 
negative, the number of digits to the left of the decimal point starting at tens. If 0 no decimal 
placing will be left.
Example:

show decimal (34.235, 2) shows 34.23

show decimal (3423.456, -2) shows 3400

show decimal ( round(0.499,0) ,2) shows 0.00
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NUMERIC COMMANDS...

FLOOR returns a number which has the number rounded down to the specified number of 
digits from the decimal point. This is similar to the deimal command excepts that it returns a 
number and not a string. If you need to display a certain number of digits after the decimal 
point use the decimal command.
Format:
FLOOR (number ,number of digits)
Arguments:
number: numerical expression
number of digits: if positive the number of digits to show at the right of the decimal point. If 
negative the number of digits to the left of the decimal point starting at tens. If 0 no decimal 
placing will be left
Example:

show floor (34.235, 2) returns 34.23

show floor (3423.456, -2) shows 3400

show decimal (floor(0.999,0) ,2) shows 0.00

ROUND returns a number which has the number rounded to the specified number of digits 
from the decimal point. It will round up or down depending on which is the closest digit. If you 
need to display a certain number of digits after the decimal point use the decimal command.
Format:
ROUND (number ,number of digits)
Arguments:
number: numerical expression
number of digits: if positive the number of digits to show at the right of the decimal point. If 
negative the number of digits to the left of the decimal point starting at tens. If 0 no decimal 
placing will be left
Example:

show round (34.235, 2) returns 34.24

show round (3423.456, -2) returns 3400

show decimal (round(0.499,0) ,2) shows 0.00
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STATISTICAL COMMANDS
These commands perform statistical calculations performed on cell ranges.

SUM adds all the values in the cell group.

Format:
SUM ( reference .. reference )
Arguments:
reference: column number or column title, row number or quoted text representing a cell title.
Example:

sum (2,1..4,3) returns the sum of all cells between column 2, row 1 and column 4, row 3

sum (“cell1”..”cell2”) returns the sum of all cells between cells with titles “cell1” and “cell2”

sum (2,1..”column1”,4) returns the sum of all cells between column 2, row 1 and the col-
umn with the title “column1” on row 4

sum ($column+1,$row..$column+2,$row+1) returns the sum of all cells 1 column right of 
current cell to 2 columns right, 1 row down

TEXT COMMANDS
These commands manipulate text. To join text you simply use the + operator.
Example:

Show “Hello.” + “How “ + “are you?” displays “Hello. How are you?” in the cell.

Show count “2FGM” + “2pt field goals” displays how many times “2FGM” is found, then 
followed by “2pt field goals. So, if there were 30 2FGM’s in the timeline, it would display “30 
2pt field goals” in the cell.

VARIABLE COMMANDS
Variables are specified using the dollar sign and a name. eg. $message = “hello”. In that 
example $message holds the text “hello” which can be used later on in the script. Variables 
only hold their value for the cell in the statistical window. A variable can hold a number, text 
or even instances in the timeline. Numbers cannot be used as the first character after the $ 
sign.
Example:
$score = count “Goal” or “Behind”
show $score
This will display the total count of “Goal” or “Behind” labels found in the front timeline. As the 
script gets larger and more complex, variables make it easier to make changes because the 
variable only has to be edited in one spot. It will not need to be changed in every part of the 
script where it is called.
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VARIABLE COMMANDS...

$COLUMN returns the column where the cell is located.
Format:
$COLUMN
Example:

show “My current column is “+$column will show a message what the column is for that 
cell in the statistical window.

$ROW returns the row where the cell is located.
Format:
$ROW
Example:

show “My current row is “+$row will show a message what the row is for that cell in the 
statistical window.

OUTPUT COMMANDS
These commands will output or effect another parts of the program like buttons in the code 
window.

PUSH BUTTON pushes the button up/down in the code input window. If this is a label button 
then you only need to use DOWN. This is an Elite feature only.
Format:
PUSH BUTTON button_name DOWN
PUSH BUTTON button_name UP
Arguments:
button_name: a string with the name of a button in the code input window. The button name 
must be in quotes.
Example:

push button “Poor Performance” down pushes the button “Poor Performance” down in the 
front code input window.

$myscore = count “Goal” where row = “My Team”
$theirscore = count “Goal” where row = “Opponent Team”
If ($theirscore > $ourscore, push button “Poor Performance” down, push button “Poor 
Performance up)
This script uses an if statement, when the opponent’s score is greater than my score, the 
“Poor Performance” button is pushed down and it starts to code the timeline. When the 
opponent’s score is equal or less than my score it pushes the “Poor Performance” button up 
and stops coding.
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OUTPUT COMMANDS

SEND changes the output value of the button in the code window with that button name. In 
order to display output in a code button, the display output option must be checked in the 
button properties for that button.
Format:
SEND value TO BUTTON “button_name”
Arguments:
value: a string or a number
button_name: a string with the name of a button in the code window. The button name must 
be in quotes.
Example:

send 37.4 to button “Button 1” changes the output value displayed in “Button 1” button in 
the front code window to 37.4.

$score = count “Goal”
send $score to button “Score”
This script changes the output value displayed in the “Score” button in the front code window 
to $score. $score counts the amount of “Goal” found in the timeline.

$shots = count instances where row = “Shot on Goal” + “ Shots”
send $shots to button “Shot on Goal”
This script sends the number of instances and appends the text “ Shots” to 
the button named “Shot on Goal”

The SEND command can send output value to any type of button whether it is a code, text 
label, or title. Graphical buttons can display output too.

The font size of the output can be changed by selecting 
the size next to the display output check box in the edit 
button properties window. When the display output option 
is checked, a question mark will appear below the button 
name on the face of the button. It will change value when 
the statistical window scripts are executed.

Information rich code windows can be created and used during live capture and code. The 
code window can be printed and used as a report or in a presentation.
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OUTPUT COMMANDS

SEND BUTTON COLOR changes the background color of the button in the code window with 
that button name.
Format:
SEND BUTTON COLOR ( red_color , green_color , blue_color ) TO BUTTON button_name
Arguments:
color: a red, green or blue color value 0->100
button_name: a string with the name of a button in the code window
Example:

send button color (100,0,0) to button “Defense” changes the background color of 
“Defense” in the front code window to red.

if ($a < 1, send button color (0,100,0) to button “Offense”, send button color 
(100,100,100) to button “Offense”)
If $a < 1 then the button will be green otherwise it will be white.

SEND TEXT COLOR changes the text color of the button in the code window with that button 
name.
Format:
SEND TEXT COLOR ( red_color , green_color , blue_color ) TO BUTTON button_name
Arguments:
color: a red, green or blue color value 0->100
button_name: a string with the name of a button in the code window
Example:

send text color (100,0,0) to button “Defense” changes the text color of “Defense” in the 
front code input window to red.

if ($a < 1, send text color (0,100,0) to button “Possession”, send text color (0,0,100) to 
button “Possession”)
If $a < 1 then the button’s text color will be green otherwise it will be blue.
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FREQUENCY REPORTS

Analyse Frequencies
This feature allows you to view:
· the number of times each Timeline code was used in the performance.
· how much time those actions took. 
· the percentage of the total performance time those actions took. 
· the mean time for each action.

1.  Choose Frequency from the Analysis 
menu in the main menu bar.

2.  In the Summary statistics window, select 
either All rows or Selected rows. If you 
want to analyse selected codes, make 
sure you have preselected the rows in the 
timeline before you start.

3.  Select the destination for the information 
in Send output radio buttons, to the 
Output Window or to an Excel File.

4. Click OK.

CREATE A DATA LIST 

A data list provides you with a complete list of events in play order. Data lists are great for 
creating customized reports in Excel. Using Excels graphs, functions and macros you can 
create some very informative reports from the timeline data.

1.  Open a timeline with the data to be 
exported.

2.  Choose Data list from the File > Export 
menu in the main menu bar.

2.  Save the data list to a file name related 
to the performance you are analysing and 
choose a target location for the file.

3.  Click on Save.

TO COPY A MOVIE FRAME TO OUTPUT

If you want to take a movie frame and transfer it to another application such as Word or 
PowerPoint, find the frame of video you want to use in a movie window, Choose Copy movie 
frame to output from the Analysis menu in the main menu bar. The frame/picture you’ve 
selected will be copied to the output Window. You can now drag a box around the picture and 
copy it to the clipboard, from there you can paste it into another application or print it.
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CREATE A KEYFRAME OUTPUT

It is sometimes necessary to find the middle frame of an instance for timing purposes and 
analysis of an action. If you want to analyze these key frames and use them in another 
application, or print them for a profile folder, first locate the instances which contain the key 
frames of interest. Then choose Key frames from the Analysis menu in the main menu bar.
The Key frames will be copied to the Output Window. You can now drag a box around the picture 
and copy it to the clipboard, from there you can paste it into another application or print it.

INSTANCE MONITOR 
The Instance monitor allows you to see the contents of an instance at a glance in a filmstrip 
style. You can select the number of frames to display as well as the frame size in relation to 
the original movie.

Use the Instance Monitor
1.  Choose Instance Monitor from the Analysis > Measurement menu in the main menu bar.
2.  This will open the monitor with grey frames because it is not linked to an instance. To display 

the required frames of an instance, click on the instance that you want to view, and select 
the size and the number of frames you wish to display.

3.  To view instances in a row, select the row of interest so all instances are highlighted, 
position the playhead where you want to start viewing, press CONTROL+TAB key to move 
from instance to instance. You can move in reverse by pressing SHIFT+CONTROL+TAB.

Mac OS X Snapshot Features
Here are some shortcuts built in Mac OS X for creating snapshots of the screen or specific 
windows.
SHIFT+COMMAND+3 will save a picture of the screen to the desktop.
SHIFT+CONTROL+COMMAND+3 will turn the mouse cursor into cross hairs where you can 
click and drag a selector on the image you want to take a snapshot of. It saves the image 
as picture on the desktop.
SHIFT+COMMAND+4 will save a picture of the screen to memory, so it can be pasted into 
another open window.
SHIFT+CONTROL+COMMAND+4 will turn the mouse cursor into cross hairs where you can 
click and drag a selector on the image you want to take a snapshot of. It saves the image 
to memory, so it can be pasted into another open window.
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DRAWING TOOLS
1. Select the pencil from the Main Tool bar.
2.  To draw a straight line, select . Click on the point of the movie frame where you want the 

line to start and drag the line to the desired end point.
4.  To change the colour of the line click on the .
5.  To change the width of the line click on the .

Changing a Drawing Object
1. Select a color from the Color palette.
2.  Select the tool you wish to use by clicking on it. This tool will remain active until another tool 

is selected or the ESC key is pressed. When the ESC key is pressed the default selection tool 
will become active.

3.  Click & drag to draw in a Movie with the active tool.
4.  To resize or change a drawing object, click the selection tool then click & drag on the handles 

of the drawing object. (Handles are the squares at the ends of the line.)
5.  To move a drawing object, click on the selection tool and click & drag on the object.
6.  To change the color of an object select the object, then click on the Color Palette tool        and 

select the desired color in the palette.
7.  To change the thickness of an object, select the object and click the Line Thickness tool 

and select the desired thickness from the list.

Using the Text Tool
1. Select a color and font size for the text.
2.  Click on the text tool   , then click on the location in a movie where you want to type the 

text.
3. Type the text in the text box.
4. To edit the text, double click on the text using the selection tool.

Customizing the Drawing Tool Bar
Most of the drawing tools you may find that you do not use and the wide tool bar can get in the 
way when presenting and drawing in full screen. To customize the appearance of the tool bar, 
click on the button in the upper right corner of the tool bar. This will reveal a check box below 
each tool. Uncheck any tools that you do not wish to see in the tool bar. Click on the button in 
the upper right corner to close and save customization. 
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STUDIOCODE DRAWING TOOL BAR

Drawing visibility turned on.

Drawing visibility turned off.

Selection Tool – Select, move, or change drawing objects 

Sets the color of the drawing objects.

Type text directly into drawing or video window. 

Sets the size of the text when text tool is used.

Draws a straight line from point to point.

Draws a straight dashed line from point to point.

Draws a straight line from point to point with an arrow head at the end of the line.

Draws a straight dashed line from point to point with an arrow head at the end of the 
line.

Draws a zig-zag line from point to point.

Draws a zig-zag line from point to point with an arrow head at the end of the line.

Draws freehand according to mouse position.

Draws an angle between three points.

Draws a rectangle with no fill color

Draws a rectangle with fill color

Draws an ellipse with no fill color

Draws a dashed ellipse with no fill color

Draws an ellipse with fill color

Sets the thickness of the selected drawing tool or object.
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DRAWING WINDOW
To create movies from pictures of your analysis use the drawing window. The drawing window 
will create movies that can be combined with other instances.

1.  Open a timeline with video, create a new drawing 
window by choosing Drawing window from the File 
> New from the main menu bar. The new drawing 
window will open up in the same size as the front 
most movie window. The drawing window should 
be the same size as the video that is going to be 
combined with it. If they do not match, a portion of 
the movie will be grey.

2.  Paste images, movie frames and drawings in the 
drawing window. Remember to CONTROL click on items to set their layers. Sometimes objects 
will be behind other objects. The background can be set by clicking on the background 
button in the tool bar and selecting the color in the palette.

3.  Save the drawing, set the length of the movie you wish to create, then press the Movie 
button. This will save the movie in the target location.

4.  From the open timeline, create a few instances. Then, open the drawing movie and use the 
Combine instance movie feature. Remember to layer the instances and drawing movies 
in the order you want them to play. Cut, Copy, and Paste, instance segments can be used 
also.

5.  Save the combined movie.

Creating Title Movies
The drawing window is great for creating title movies that you can paste in front of an 
instance movie. This lets the viewing audience know what is coming up and helps keep 
them focused on the subject of the presentation.
Create a folder called Titles. Open a drawing window, paste your logo in the window, set 
the background color, add some drawing objects and color them to match your scheme. 
Add some large bold text in the middle of the window and save the drawing in the Titles 
folder.
Edit the bold text to match the subject of the instance movie, this might be the row 
name. Then, create the movie and save it in the Titles folder with the name of the bold 
text. Repeat this process for all the categories of instance movies you will be presenting. 
Since it is very common that you will need to use these titles over and over, they are now 
created and saved in the Titles folder for future use.
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CREATE ANGLES AND MEASUREMENT LINES
The measurement tools, line and angle, can be found under the Analysis > Measurement 
menu. By using known distances in a frame of video, you can accurately measure other 
distances relative to a known distance. Known distances that can used in a video frame are 
landmarks such as a goal or field marker. You can use the landmark to set the relative scale 
of the line tool.

Line Measurement Tool

Choose Line from the Analysis > Measurement menu in the main menu bar.
A line will appear in the middle of the screen. The 
measurement tool has a number of invisible handles 
on it. On the line measurement tool there are three 
handles to grab. Move the mouse pointer over the 
ends of the line tool, the cursor changes to a cross-
hair (1+2). Click on these areas to move that end of 
the line. Move the mouse pointer over the center of 
the line tool, the cursor changes to a finger pointing 
(3). Click on this area to move the line tool.

Set the Line Parameters
Press CONTROL and click on one of the lines to set the Line Color, Line Thickness, Vertical 
Scale, Horizontal Scale, Make Vertical, Make Horizontal.

Setting the Scale Factor for the Line Length
You can use the vertical and horizontal scale option to scale the lines and angles to reflect real 
world values.

·  To set the Vertical scale for a movie, move the line over a known measurement in the movie, 
select the “Vertical Scale Option” and type in the real world value. 

·  To set the horizontal scale for a movie, move the line over a known measurement in the movie, 
select the “Horizontal Scale Option” and type in the real world value.

All angles and lines should be recalibrated accordingly.

The biomechanical measurement tool can be used either on the preview movies or in full 
screen mode – where greater precision of measurement is available, because of the larger 
picture size.

The line tool is most effective for movies where the camera is fixed and does not zoom in and 
out.

200.00

3
200.00 21
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Angle Measurement Tool

Choose Angle from the Analysis > Measurement menu in the main menu bar.
An angle will appear in the middle of the screen. 
The measurement tool has a number of invisible 
handles on it. On the angle measurement tool there 
are five handles to grab. Move the mouse pointer 
over the ends of the line tool, the cursor changes to 
a cross-hair (1+2+3). Click on these areas to move 
the ends of the angles and the vertex. Move the 
mouse pointer over the middle of either arm, the 
cursor changes to a finger pointing (4+5). Click on 
this area to move the angle tool.

The Measurement tools can be cleared by right clicking on the tool and selecting delete 
or delete all.

SCOREBOARD INTERCUT MOVIE

1. Capture and code the master movie, commonly the sideline angle.
2.  Simultaneously capture the movies from the other camera locations.
3. Open all the timelines to be used in the intercut.
4. Set the timeline cursors at the same start point in all timelines.
5.  In the master timeline select the rows containing the instances to  

intercut.
6. From the Main menu line select Analysis > Intercut.

1

2
3

4

5
90.00
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USING A REMOTE CONTROL

The Apple Remote can be used in various ways. These peripheral products are great tools for 
boardroom presentations of coded video.

This remote can be customized in the software preferences.

Each button on the remote can be assigned a movie, drawing tool, or code button hot key 
function. Click on the button type drop down and select from Code, Movie, or Drawing button.

Code buttons can be assigned to match hot keys in a code window. When the button window is 
open and in code mode, the button can be pressed on the remote and it will push that button 
in the code window.

Movie buttons are the various playback features of the software that 
can be performed in a movie window using the keyboard shortcuts.

Drawing buttons will enable different drawing tools in the drawing tool 
bar. This is very handy when presenting in full screen.
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A

Angles  4.34
Auto save  2.4

B

Button
Code  1.1, 1.2, 1.8, 3.1, 3.2, 3.4, 3.5, 3.8, 3.10, 3.13, 3.15, 3.21, 3.22, 3.25, 3.26, 3.27, 

3.40, 4.36
Duplicate  1.7, 1.8, 3.8, 3.25
Edit  3.3, 3.4, 3.7, 3.9, 3.10, 3.11, 3.23, 3.25, 3.33, 3.49, 4.29, 4.31
Graphic  3.2, 3.4
Layers  3.8, 3.12
Title  1.2, 1.3, 1.4, 3.2, 3.3, 3.4, 3.5, 3.7, 3.8, 3.27, 3.29, 4.33

C

Capture  1.1, 1.2, 1.4, 3.14, 3.15, 3.16, 3.17, 3.19, 4.35
Code  1.1, 1.2, 1.8, 2.2, 3.1, 3.2, 3.4, 3.5, 3.8, 3.10, 3.13, 3.15, 3.21, 3.22, 3.25, 3.26, 3.27, 

3.40, 4.36
Code Button  1.2, 3.2, 3.8, 3.27, 3.40
Code Window  1.2, 3.1, 3.8, 3.13
Combining Timelines  4.3
Commando  4.36
Converting  3.50, 3.51, 3.52
Custom Lead Time  3.9

D

Database  1.2, 4.3
Default Lead Time  3.9
Dongle  2.1, 2.2
Drawing Tool Bar  1.4, 4.31, 4.32
Drawing Window  4.33
DV Video  3.53

E

Edit List  4.29
Equalize video and sound  2.4, 3.17
Export  1.4, 3.50, 3.53, 4.3, 4.29



114

Part 5  Studiocode Index

F

Frequency Reports  4.29
Full screen  1.4, 1.6, 1.7, 3.32, 3.53, 4.2, 4.31, 4.34, 4.36

H

Hot Keys  3.10, 3.11

I

Instance  1.2, 1.6, 3.10, 3.20, 3.23, 3.24, 3.30, 3.31, 3.32, 3.33, 3.34, 3.49, 4.1, 4.30
Instance adjustments  3.20, 3.24
Instance Edit  3.23
Instance Monitor  4.30
Intercut  4.35

K

Keyboard Shortcut  1.5, 1.6, 1.7, 1.8

L

Lag Time  1.3, 3.10
Language  2.2, 2.3
Lead Time  1.3, 3.9
Line  3.15, 4.31, 4.34
Lines  4.34
Links  3.12
Loop  1.4, 3.32

M

Movie  3.28, 3.29, 3.30, 3.31, 3.32, 3.33, 3.34, 3.49, 3.50, 3.51, 3.52, 3.53, 4.1, 4.2, 4.29, 
4.30, 4.31, 4.33, 4.34, 4.35, 4.36

MPEG-4  3.50, 3.52, 3.53

N

Nudge  1.6, 3.18, 3.20

O

Output  4.29, 4.30
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Overlay  1.6, 3.48, 4.1

P

Package  1.3, 2.3
Preferences  1.8, 2.3, 2.4, 3.19, 3.53
Present Movie  1.4

R

Reference Movies  3.52
Registration  2.1, 2.2

Dongle  2.1, 2.2
Online  2.1, 2.2

Remote  3.11, 4.36
Row  3.24, 3.25, 3.26, 3.30

S

Shortcut  1.5, 1.6, 1.7, 1.8
Snapshot  4.30
Sort  3.27
Sound  3.14, 3.15, 3.17, 3.51
Stack  1.6, 4.2
Synchronization  3.17, 3.18, 4.2

T

Timeline  3.21, 3.22, 3.23, 3.24, 3.26, 4.2, 4.29
Title  1.3, 3.2, 3.5, 4.33
Trim  3.23

V

Video Out  3.53
Volume  1.4, 3.32


